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Overview

This document describes:

e The New Featuresinthe 8.12.1 release

o The Issues Addressed inthe 8.12.1 release

o The PowerPacks included in the 8.1210 release

o New and Updated Packagesinthe 8.12.1 release

o The Beta Features available with the 8.12.1 release

o Disabling the Knowledge Base

o Special Upgrade Process for FIPS-Compliant Systems

o Special Considerations for Systems Running 8.4.1 or Earlier

o Upgrade Process for 7.x Systems

o Upgrade Process for Systems Running 8.4.0 and Later

o Upgrading MariaDB

e Manual Updates for 8.4.x Systems Updated to 8.12.1

o Rebooting Appliances

o The features deprecated inthe 8.12.1 release

WARNING:

Do not import 8.12.0 or 8.12.1 if you do not plan to immediately consume the 8.12.x
line of releases. After you import an 8.12.0 release, all appliances in your SL1 system will now
use the new system update. After you import an 8.12.0 release, you will not be able to stage
and deploy any versions of SL1 previous to 8.12.0 or apply patches to versions of SL1 previous to

8.12.0.

WARNING:

To install 8.12.1 and its new System Updates tool, you have must have already imported,
staged, and deployed 8.4.0

WARNING:

8.12.1 includes important security updates that require you to reboot all appliances
after installing 8.12.1. If you would like assistance in planning an upgrade path that meets your
security needs while minimizing downtime, please contact your Customer Success Manager.

WARNING:

8.10.0 and later releases do not support Data Collectors and Message Collectors
running the CentOS operating system. If your system includes Data Collectors and
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Message Collectors running the CentOS operating system, contact your Customer
Success Manager for details on upgrading Data Collectors and Message Collectors to
Oracle Linux before installing 8.12.1.

WARNING:

To apply updates to an existing Data Collector, that Data Collector must be a member of a
Collector Group. In some SL1 systems, users might have to create a Collector Group for a single
Data Collector.

WARNING:

Sciencel ogic strongly suggest you contact Customer Support or your Customer Success
Manager to plan your migration from CentOS (versions of SL1 priorto 8.1.1) 10 8.12.1.

WARNING:

7 .x systems must be upgraded to 7.8.5 before migration to the 8.9.0 release (using a special
migration patch). After migration to 8.9.0, users can upgrade to releases later than 8.9.0.
Upgrading to 8.10.0 and later requires re-building all Data Collectors and Message Collectors.
Please contact your Customer Success Manager to begin a discussion on the migration plan that
is appropriate for your system.

WARNING:

The Knowledge Base includes known vulnerabilities for cross-site scripting and SQL injection. If
you are updating from a previous installation, Sciencelogic strongly recommends that you
disable the Knowledge Base.

WARNING:

If your system is not currently running a recent release, the upgrade process includes importing
multiple upgrade files. You must wait until an update file has imported successfully (i.e. the
Import Status column displays Complete in both the EM7 Release pane and the Sciencelogic
OS pane) before importing the next update file.

CAUTION:

Sciencelogic recommends that Systems running an AP2 version earlier than 5.55.1.3 upgrade
their version of AP2 before upgrading to 8.12.1. For details, see the manual Using the New
User Interface, section on Managing New Features on the Content Management Page.

CAUTION:

Before installing a release, Sciencelogic recommends that you verify that recent backups are
available for your system.
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CAUTION: During the normal system update process, multiple processes are stopped and restarted. This
might result in missed polls, gaps in data, and/or unexpected errors. Sciencelogic recommends
that you always install Sciencelogic releases during a maintenance window.

CAUTION: The Sciencelogic system update process starts a background process that can perform any
required post-upgrade tasks. The post-patch update process is automatically stopped after 24
hours. However, depending on the size of your database as well as the version from which you
are upgrading, the post-upgrade tasks can take several days to perform. If the post-patch update
process is stopped after 24 hours, the process will automatically re-start and continue processing
from the point at which it was stopped. If you see an event that indicates the post-patch update
process was stopped, you do not need to contact Sciencelogic support for assistance until you see
the same event for three consecutive days.

TIP: Before you install a Sciencelogic release, Sciencelogic recommends reviewing the hardware
specifications of all the appliances in your system to ensure they meet the requirements for the current
usage of your system. For more information, see https://support.sciencelogic.com/s/system-requirements

TIP: Sciencelogic regularly uploads new and updated PowerPacks to the Customer Portal before packaging
those PowerPacks in a system update file. For more information, see
https://portal.sciencelogic.com/portal/powerpacks.

New Features in 8.12.1

8.12.1 Unified Ul includes the following new features:

NOTE: The unified Ul includes pages from the SL1 Classic Ul, displayed in either the SL1 Classic Ul and
ported fo the SL1 Next Ul.

Content Libraries
o Updated pip, setuptools, and wheel to latest versions, to support third-party content libraries.
Dynamic Applications

« Improved the performance of the Dynamic Application process that checks each auto-disabled collection
object on a device and re-enables the collection object when appropriate.

Form Fields

o Improved custom form fields in the Application forms page (System > Customize > Form Fields). In the
Form Creator modal page, the field types Varchar32, Varchar48 and Varcharé4 have been replaced with a
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field of type TextArea. The new fields can include up to 64K characters
Logging

o Added new page PHP Developer Logs (System > Tools > PHP Developer Logs) to SL1. These logs aid
Sciencelogic Customer Support when troubleshooting problems with the user interface.

PhoneHome

« In aHigh Availability system, only the Database Server that is also the PhoneHome control node may
generate a PhoneHome token for the Data Collectors. (Support ID: 153173) ( Support ID: 161661)(Support
ID: 172370)(Case 00006471)

PowerShell

o IfaPowerShell Dynamic Application terminates before closing its open connections, SL1 will automatically
close the open PowerShell connections.

o PowerShell Dynamic Applications that are cache producers or cache consumer now successfully collect data
from merged devices.

System Update
o Improved System Updates (System > Tools > Updates). After successful deployment or successfully staging a

later version of an update, System Update now removes packages that were copied to each SL1 appliance
during staging.

8.12.1 Next Ul includes the following new features:

NOTE: Features in this section are not available in the SL1 Classic Ul.

User Interface Version

e 8.12.1 includes the following version of the user interface:

o AP2 5.125.44.
General
o When searching, you can click the menu icon to the right of the Search field to open a menu containing

related search criteria. In that menu, you can select a search criteria and type additional search information.

o Ifyou select a date-related search criteria from the list of criteria in Basic Search, you can use a drop-down
calendar to select a specific date.

« Basic Search and Advanced Search were updated to include better search queries and usability.

o Foran Administrator user, the End User License Agreement (EULA) appears the first time that user logs into
SL1. The user must agree to the terms before using SL1.

Applications
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« From the Application Investigator page, you can view the details of that application, view and add
application components or devices to that application, and edit the status policy aligned with that application.

o The [Rules] button on the [Devices] tab for an application component lets you define the processes and
arguments to monitor for that application component.

o The [Define these with a Query ]button on the [Devices] tab for an application component lets you update
the set of devices in that application component.

« You can edit an application component by clicking the [Actions] button for that component on the
Applications page.

« You can create static or dynamic searches for the devices you want to add to an application component.

« You can view both statically defined and dynamically defined application components on the Application
Investigator page.

« When creating an application or an application component, you can search for business, IT, and device
services.

o Improved error messaging was added if you try to add non-devices to an application component.
Dashboards

« You can now create Application and Application Component widgets.

o The Auto-Select option was moved from the All Filters window to the widget creation process, where you
can select the number of items that are automatically selected in the context-driving widgets.

o InaService widget, you can link directly o another dashboard or item related to that service.

o The dashboard creator can choose a specific dashboard from a list that is linked to a leaderboard, so the user
can specify a dashboard without copy and pasting a URL and using a parameter.

o Ifadashboard creator doesn't enter a new name for a map widget, the name of the map will be used.

o The icon in a service tile widget is still visible even when the service is unavailable.

o Leaderboard bar chart widgets can now drive context.

« Event widgets can now drive context.

o Selecting items in a map widget will drive context in other widgets.

« Custom Attributes can now be selected under Metrics and Properties when creating a device table or event
table widget.

Devices

o You can change the aligned Device Class from the Info drop-down on the Device Investigator page for a
device.

« You can generate a report for a device from the Device Investigator page.
« The [Settings] tab on the Device Investigator page was updated with additional options.

o On the [Events] tab for the Device Investigator page, you can toggle between cleared and active events for
a device.

o On the [Events] tab for the Device Investigator page, you can use the Search field to filter the list of events
for that device.
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o On the [Interfaces] tab for the Device Investigator page, you can click the interface name from the list of
interfaces to open the Interface Properties page for that interface.

o Ifan SL1 system is configured to use Maps, the [Map] tab on the Device Investigator page displays by
default.

o The Tools drop-down on the Device Investigator page does not display if the user does not have
permissions for the device tools. The Tools drop-down now includes an Availability tool.

o You can drag and drop the various tabs on the Device Investigator page to rearrange the order of the tabs.

o Hovering over a column in the Devices page displays a ToolTip with the complete value if the value was cut
off by the column width.

« You can now assign icons to devices.

« Users need proper permissions to edit Device Categories and Device Classes.
Events
« You can view the automations that were run on a certain event by selecting View Automation Actions from the

Actions menu on the Events page.

o From the View drop-down on the Events page, you can toggle the ability to group events generated from a
Business Service, events from its IT Services and their Device Services, and events from the underlying
devices.

o From the View drop-down on the Events page, you can specify a time frame for SL1 to auto-refresh and
display new events. You can also click the Refresh icon at the top right of the Events page table to manually
refresh the list of events.

o The Actions menu from the Events page is also available at the top right of the Event Investigator page for
an individual event.

o The Card view for the Events page has been deprecated.

o Custom Attributes can now be selected to display as columns in the Events page.
Maps

« The Design pane for a map was updated and streamlined, and the configurable design options now include
Tiered Hierarchy, Hierarchy, and Force Directed. For more information about changing the appearance of a
map, see the Maps manual.

o The Filters pane for a map was updated and streamlined, and the counts for each node type now displays in
a badge next to the node type.

« You can access the Design pane and Filters pane from the new Settings drop-down on the navigation bar
in a Maps window.

o You can hover over a node in a map to view a pop-up Properties pane with the relevant details, or
metadata, for that node. If you click to select a node and then click the [Selections] button, the metadata
displays in a Properties pane fo the right of the map.

« Ifyou select a node in a map, you can click the [Events] tab in the Properties pane to monitor the events on
that node. If you do not have the relevant permissions for viewing events, the [Events] tab does not appear.

o ForaService node or an Application node, the Availability, Health, and Risk values now appear on the
Properties pane.
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o You can use the Search field at the top of a map page to search for specific nodes on the current map.
Nodes that do not meet the search criteria are grayed out in the map.

o The Zoom feature for viewing a map was updated to ensure that the node details display clearly when
zooming in or out.

o Onthe [Nodes] tab of the Design pane, if you have the Show External Labels toggle selected, you can
expand the Label Fields section and edit the type of label that displays under each node. For example, you
could edit the external labels to display the organization name for each node.

o Just like Dashboards, any Maps that you create can be Private (viewable only to you), Public (viewable to
users in all organizations using SL1), or viewable by Specific Organizations. You must have the relevant
permissions to create a map, and the state of a new map is Private by default.

o Depending on the permissions assigned to users, some users will be able to create and edit maps and select
the default layout. Meanwhile, other users will only be able to view and filter existing maps and update the
layout of existing maps.

« Tocreate a copy of an existing map, open the map, click the Save Map drop-down, and select Save As
Copy.

Issues Addressed in 8.12.1

The following issues are addressed in the 8.12.1 Unified Ul:

NOTE: The Unified Ul includes pages from the SL1 Classic Ul, displayed in either the SL1 Classic Ul and
ported fo the SL1 Next Ul.

Asset Records

o The BIOS/EPROM field in the Asset Configuration page (Registry > Assets > Asset Manager > create/edit >
Configuration) can now include up to 64 characters. (Support ID: 177307)(case 00022795)

Collector Groups

« Inthe Collector Group Management page (System > Settings > Collector Groups), renamed the field Max
Allowed Collector Outage to Collectors Available For Failover and addressed an issue where SL1 was
not following the failover rules defind in this page.. If Collector Failover is enabled, and the number of
available Data Collection servers is less than the value in the Collectors Available For Failover field, SLT will
not failover within the Collector Group.

Dashboards

o The onboarding dashboard now tries authenticating with the "EM7 internal" method first and no longer
displays spurious errors about LDAP authentication. (Support ID: 175680)(case 20793)

o Dashboard widgets of type iframe that use host name-base proxies now load without security errors. (Support
ID: 177222) (case 24860)
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NOTE: If you have enabled the Force Secure HTTPS field in the Behavior Seftings page (System > Settings >
Behavior), when you supply a URL in the iframe widget, that URL must also use HTTPS. If you chose
not to enable Force Secure HTTPS field in the Behavior Settings page (System > Seftings >
Behavior), you can use HTTP in the iframe widget and perform the following security work-around: *

1. Either goto the console of the Database Server or All-In-One appliance or open an SSH session to he
Database Server or All-In-One appliance.

2. Use vito edit the file /etc/nginx/conf.d/sm7ngx_web_ui.conf

3. Afterthe last " listen® directive, add the following lines:

{code}

if ($scheme = http) {

return 301 https://S$hostS$request uri;
}

{code}
Documentation
« Edited the Installation and Initial Configuration manual. Edited the chapter for the PhoneHome configuration.

(Support ID: 108082)

« Edited the Discovery and Credentials manual. Added Caution text that states that if you enter both the
hostname and IP address of the same device, SL1 will discover two duplicate devices. (Support ID: 175871)
(case 21902)

« Edited the System Administration manual, the Device Management manual and the Discovery and
Credentials manual. The Ping and Poll Timeout field has been edited to include both discovery and
availability monitoring. (case 0029032) (Support ID: 177881)

« Edited the System Administration manual. Added a new section on Disabling phpMyAdmin, with updated
steps. (Support ID: 177863) (case 287438)

o The release notes for 8.12.1 and the System Administrators manual now specify that to apply updates to an
existing Data Collector, that Data Collector must be a member of a Collector Group. (Support ID: 176540)
(case 24412)

o lwould fell you an IPv4 joke, but all the good ones have been exhausted.
Dynamic Applications

« Fixed problems with auto-disabling and auto-enabling of collection for collection objects. In the Dynamic
Application Manager page, ( System> Manage > Applications) the Subscribers column now accurately
displays the number of subscribed devices. ( Case 00025077) (Support ID: 152484) (Support ID: 176929)
(Support ID: 159436)

IT Service Policies

o Ifone or more devices in an IT Service policy go into maintenance mode, with collection enabled, SL1 will
continue aggregating health metrics for those devices, and those devices will not appear as unavailable to
the IT Service. (Support ID: 176826) (case 25061)

Network Interfaces
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o When an inferface switches between 32-bit counters and 64-bit counters, SL1 will manage the new counter-
value and will not produce unrealistic spikes in bandwidth usage. Bandwidth graphs, reports, and events will
no longer show spikes in bandwidth usage when an interface switches counter type. (Support ID: 173458)
(case 6457) (case 14275) (case 17686) (case 13677) (case 15309) (case 21949) (case 21489) (case
28186)

o Allinterface data (bandwidth, errors & discards, and packets) is now successfully collected with all possible
combinations of Enable Variable Rate Interface Counters (in System > Seftings > Behavior) and high

precision_if _collect (manually setin master.system custom_config set field value). (Support ID: 177371)
(case 28392) (Support ID: 174594) (case 12174) (case 24323) (Support ID:174400) (case 15574)

o The SL1 process "Data Collection: Interface Bandwidth: no longer generates an unhandled exception when
one or more network aliases include a forward-slash character ("/"). (Support ID: 160981) ( case
00026692)

PhoneHome

« In aHigh Availability system, only the Database Server that is also the PhoneHome control node may
generate a PhoneHome token for the Data Collectors. (Support ID: 153173) ( Support ID: 161661)(Support
ID: 172370)(Case 00006471)

Security

o AllSLT cookies now have their secure flag setto "yes". (Support ID: 177838) (Case 29364)
o The page <ip address>/em7/license.html no longer allows page caching. (Support ID: 177837) (case
00029365)
SNMP Traps

« Ifyou create a trap filter in the SNMP Trap Filter page ( Registry > Events > SNMP Trap Filters) and specify a
value only in the Trap OID Filter field (and specify no values in the Varbind OID Filter field or the Varbind
OID Pattern field), SL1 will successfully filter traps with a matching OID. When a trap is filtlered, the Message
Collector receives the trap, but does not store the trap, does not act on the trap, and does not pass the trap on
to be examined by the Sciencelogic event engine.(Support ID: 178728) (Case 35100)

System Update

o The database processes that occur during system update and that were affecting high-frequency collection
and medium-frequency collection have been improved for better performance. (Support ID: 178910) (Case
38635)

Sciencelogic API

« GQL queries and REST APl queries for device relationships no longer run slowly, cause timeouts, and affect
the performance of the Database Server. (Support ID: 178242) (case 00031725)

o You can now successfully create and update an asset record with a POST method. (Support ID:178837)
(case 37845)
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The following issues are addressed in the 8.12.1 Next Ul:

NOTE: Features in this section are not available in the SL1 Classic Ul.

General

o Addressed an issue to ensure that SL1 properly handles user passwords with special characters such as "%"

C]I']d n@n.

o Addressed an issue where the Search feature did not provide results when searching for Custom Attribute
labels or values.

Business Services

o Addressed an issue where the [Overview] page for a Device Service displayed an empty set of devices,
stating that "Selected device services do not currently contain devices."

PowerPacks Released with 8.12.1

When patchingto 8.12.1, please verify whether any PowerPacks that your system is currently running are “newer”
than the PowerPacks included in this SL1 update. If the PowerPack on your system is "newer" than the one included
with the SL1 update, you might see spurious error messages. To avoid spurious error messages:

1. Gotothe Device Components page (Registry > Devices > Device Components).

2. Find each root device associated with the PP you do not want to update and select its checkbox.

w

Click the Select Action field and choose Change Collection State: Disabled (recursive). Click the [Go]
button.

Wait five minutes affer disabling collection.

install the SL1 update.

Goto the Device Components page (Registry > Devices > Device Components).
Select the checkbox for all affected root devices.

In the Select Actions drop-down list, select Change Collection State: Enabled (recursive).

Click the [Go] button.

0V o N o A

The 8.12.1 release includes the following PowerPacks that are new or updated and included with the release:

o Net-SNMP Base pack, v101
« F5BIG-IP,v102

Documentation and release notes for each PowerPack are available on the Sciencelogic Portal.
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If you are currently using the Amazon Web Services PowerPack included in the 8.1.0 platform
release orincluded in an earlier platform release, please read the release notes for Amazon Web
Services before migrating to later versions Amazon Web Services PowerPack. You must first
migrate to Amazon Web Services, v100 before upgrading to later versions of the Amazon Web
Services.

If you are currently using the VMware: vSphere Base Pack, v202 or earlier, please read the
migration instructions in the release notes for VMware: vSphere Base Pack, v203 and migrate to
v203 before upgrading fo later versions of the PowerPack.

NOTE: The "Microsoft SharePoint' PowerPack is no longer included with platform releases. The PowerPack is
superseded by the "Microsoft: SharePoint Server' PowerPack.

NOTE: The "Microsoft SQL Server" PowerPack is no longer included with platform releases. The PowerPack is
superseded by the "Microsoft: SQL Server' and "Microsoft: SQL Server Enhanced" PowerPacks.

NOTE: The "Microsoft Exchange" PowerPack is no longer included with platform releases. The PowerPack is
superseded by the "Microsoft: Exchange Server 2010" and "Microsoft: Exchange Server 2013"
PowerPacks.

NOTE: The "Microsoft HyperV" PowerPack is no longer included with platform releases. The PowerPack is
superseded by the PowerPack "Microsoft: Hyper-V Server'.

New and Updated Packages in 8.12.1

The 8.12.1 release includes multiple kernel updates and security updates. These important security updates
will not take effect until each appliance in your system is rebooted. If you would like assistance in
planning an upgrade path that meets your security needs while minimizing downtime, please contact
your Customer Success Manager.

Beta Features

The following beta features are included in the 8.12.1 release:
o Manual Device Discovery

o This beta feature allows monitored devices to be added manually instead of via a discovery session.
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o Run Book Actions: Custom Action Type

o ARun Book Action of type "Custom Action Type" executes a reusable snippet. Unlike the Action Type
"Snippet', a Custom Action Type can accept input parameters (in a JSON format) and create output
(in a JSON format). A Custom Action Type allows a single snippet fo be used in multiple Action
Policies, each time with different inputs and different outputs. A Custom Action Type is associated with
an Execution Environment. An Execution Environment contains the supporting modules and code
(Content Libraries) required by the Custom Action Type. Content Libraries allow snippet developers to
isolate the “heavy weight”, re-usable code and write “light weight” snippets that call the Content
Libraries.

o PowerPacks: Beta versions of the following PowerPacks are available. You can download then from the
Customer Portal and import them into SL1:
o Alibaba Cloud: Aliyun
o AMQP: RabbitMQ
o Cisco: ACI Multi-Site Manager
o Cisco: Cloud Center
o Cisco: Contact Center Enterprise
o Cisco: Hyperflex
o Cisco: Medianet/Mediatrace
o Cisco: Meraki (API)
o Cisco: Tetration
o Cisco: UC Ancillary PowerPack. Includes Dynamic Applications for monitoring Cisco CUBE devices.
o Cisco: UCS Director
o Cisco: Unity Express (Download from the Customer Portal and Importinto SL1)
o Docker (Download from the Customer Portal and Import into SLT)
o ELK: AWS CloudTrail
o ELK: Azure Activity Log
o F5:BIG-IP DNS
o Google Cloud Platform
o Hitachi Data Systems: VSP
o Kubernetes
o Link Layer Neighbor Discovery (Download from the Customer Portal and Importinto SL1)
o Microsoft: Office 365
o Microsoft: Windows Server Event Logs

o Palo Alto (Download from the Customer Portal and Importinto SL1)
To install a beta PowerPack:

1. Go to the PowerPack Manager page (System > Manage > PowerPacks).
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2. Selectthe [Actions] menu and select Install PowerPack. The PowerPack Installer modal page is displayed.

3. Selectthe lightning-bolticon (" ) for the PowerPack you want to install. Information about the contents of the
PowerPack and the installation process is displayed.

4. Selectthe [Install] button.

TIP: By default, installing an updated version of a PowerPack will overwrite all content in a PowerPack that has
already been installed on the target system. You can use the Enable Selective PowerPack Field
Protection setting in the Behavior Settings page (System > Settings > Behavior) to prevent new
PowerPacks from overwriting local changes for some commonly customized fields.

Disabling the Knowledge Base

The Knowledge Base includes known security vulnerabilities. SciencelLogic no longer supports the Knowledge
Base

« Sciencelogic strongly recommends that existing users disable the Knowledge Base. 8.9.2 and later releases
provides a new setting in the silo.conf file to disable the Knowledge Base.

o Fornew installations that installed 8.12.1, the Knowledge Base will be disabled by default.

WARNING: The Knowledge Base includes known vulnerabilities for cross-site scripting and SQL injection.
Sciencelogic strongly recommends that you disable the Knowledge Base.

To disable the Knowledge Base:

1. Use SSH to connect to the Administration Portal and Database Server or All-In-One (all SL1
appliances that provide a web interface).

2. Use an editor like vi and edit the file /etc/silo.conf. In the LOCAL section, add the line:

kbase disabled=1

4. Use an editor like vi and edit the file /etc/siteconfig/siloconf.siteconfig. In the LOCAL section, add
the line:

kbase disabled=1
5. Open a browser session and login to the SL1

6. From the hamburger menu ( = ) in the upper right, select Clear SL1 System Cache.

7. Upon your next login, the Knowledge Base tab will not appear. Attempts to access the tab will result in
an "Access Denied" error message.
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Special Upgrade Process for FIPS-Compliant System

FIPS-compliant systems should use the classic SL1 user interface. The Unified User Interface is not yet FIP-
compliant.

FIPS-compliant systems (those that are FIPS 140-2 enabled) should manually upgrade to the latest version of
MariaDB.

The platform patch will automatically update MariaDB-client, MariaDB-common, and MariaDB-shared RPMs but
will not update the MariaDB Server.

Special Considerations for Systems Running 8.4.1 or Earlier

WARNING: 8.10.0 and later releases do not support Data Collectors and Message Collectors
running the CentOS operating system. If your system includes Data Collectors and
Message Collectors running the CentOS operating system, contact your Customer
Success Manager for details on upgrading Data Collectors and Message Collectors to
Oracle Linux before installing 8.12.1.

8.4.2 included a new feature for Ticketing. The Note Editor for tickets includes a drop-down menu where the user
can specify that the note be saved as Plain Text or HTML. Ticket notes created in the APl can also be saved as Plain
Text or HTML. HTML is the default format for ticket notes in both the Note Editor and the API.

This new feature required a change to the database schema that will be performed immediately after a system is
upgraded to 8.4.2 or later for the first time. If your system has not been upgraded to 8.4.2 or later, this schema
change will be performed after you upgrade.

During the post-patch process, all existing ticket notes will be migrated to the new schema in batches. During the
migration, all ticket notes will be unavailable. The user interface and APl will not display ticket notes. Ticket notes
cannot be viewed or updated during the post-patch process. On a system that included 2,000,000 ticket notes,
this process took approximately 6 hours.

If you require access to all ticket notes immediately after installing an 8.4.2 or later release, contact
Sciencelogic Customer Support for details on manually updating the database schema before you
upgrade to 8.4.2 or later.

The 8.4.2 release also changed the firewall on all appliances from iptables to firewalld. If you are currently
running a release earlier than 8.4.2 and have added one or more custom firewall rules, such as a non-standard
port for Phone Home Collectors, these rules must be migrated before upgrading to 8.8.1. Please contact
Sciencelogic Support for more information.
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Upgrade Process for 7.x Systems

WARNING: 8.10.0 and later releases do not support Data Collectors and Message Collectors
running the CentOS operating system. If your system includes Data Collectors and
Message Collectors running the CentOS operating system, contact your Customer
Success Manager for details on upgrading Data Collectors and Message Collectors to
Oracle Linux before installing 8.12.0.

WARNING: 7 .x systems must be upgraded to 7.8.5 before migration to the 8.9.0 release (using a special
migration patch). After migration to 8.9.0, users can upgrade to releases later than 8.9.0.
Upgrading to 8.10.0 and later requires re-building all Data Collectors and Message Collectors.
Please contact your Customer Success Manager to begin a discussion on the migration plan that
is appropriate for your system.

The 8.1.1 release included a complete update of the Sciencelogic appliance operating system from CentOS
5.11 to Oracle Linux. Major operating system components, including the database, web server, and High
Availability/Disaster Recovery packages have been updated or replaced by new industry-standard packages.

When upgrading from version 7.8.5 to version 8.9.0, each appliance must be migrated to 8.9.0 and the Oracle
Linux 7.5 operating system.

Upgrade from 7.xto 8.9.0

WARNING: Sciencelogic strongly suggest you contact Customer Support or your Customer Success
Manager to plan your migration from CentOS (versions of SL1 priorto 8.1.1) 10 8.9.0.

The process of migrating an existing system to 8.9.0 includes multiple additional steps that will vary depending on
the current architecture. Please contact your Customer Success Manager to begin a discussion on the migration
plan that is appropriate for your system.

The following is the general process for migrating from 7 .xt0 8.9.0. This is a high-level description only. For
details, contact Customer Support or your Customer Success Manager.

o The existing system must be upgraded to 7.8.5 before the upgrade.
o Run the 8.9.0 migration patch.

NOTE: See the separate Migration document for detailed instructions on how to perform the migration steps.
Before you migrate t0 8.9.0, please contact your Customer Success Manager.
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o Use the 8.9.0ISO to reinstall all Database Servers or All-In-One Appliances. Data is migrated using a
logical backup while the database on the existing system is stopped. The downtime of this operation can be
mitigated in several ways depending on the current architecture.

o Use the 8.9.0 ISO to reinstall all Administration Portal appliances.

« After reinstalling all Database Servers and Administration Portals, the system is operational and can be

upgraded.
o Toupgradeto 8.12.1, see the section on Upgrade Process for Systems Running 8.4.0 and Later.

Features Not Currently Supported by the 8.x Releases

The following functionality that was available in previous releases is not currently available in the 8.12.0 release,
but will be re-added in a future release:

« Configuring two All-In-One Appliances for Disaster Recovery
« Applying a patch manually with the apply_patch script

Upgrade Process for 7.x Systems
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Upgrade Process for Systems Running 8.4.0 and Later

WARNING:

Do not import 8.12.0 or 8.12.1 if you do not plan to immediately consume the 8.12.x
line of releases. After you import an 8.12.0 release, all appliances in your SL1 system will now
use the new system update. After you import an 8.12.0 release, you will not be able to stage

and deploy any versions of SL1 previous to 8.12.0 or apply patches to versions of SL1 previous to
8.12.0.

WARNING:

To install 8.12.1 and new System Updates tool, you have must have already imported,
staged, and deployed 8.4.0

WARNING:

8.10.0 and later releases do not support Data Collectors and Message Collectors
running the CentQOS operating system. If your system includes Data Collectors and
Message Collectors running the CentQOS operating system, contact your Customer
Success Manager for details on upgrading Data Collectors and Message Collectors to
Oracle Linux before installing 8.12.1.

WARNING:

8.12.1 includes important security updates that require you to reboot all appliances
after installing 8.12.1. If you would like assistance in planning an upgrade path that meets your
security needs while minimizing downtime, please contact your Customer Success Manager.

WARNING:

If your system is not currently running a recent release, the upgrade process includes importing
multiple upgrade files (8.5.0 > 8.6.0 > 8.7.0 > 8.8.0 > 8.9.0 > 8.10.0 > 8.12.0 >
8.12.1). You must wait until an update file has imported successfully (when the Import Status
column displays Complete) before importing the next update file.

WARNING:

To apply updates to an existing Data Collector, that Data Collector must be a member of a
Collector Group. In some SL1 systems, users might have to create a Collector Group for a single
Data Collector before applying updates.

Sciencelogic recommends that Systems running an AP2 version earlier than 5.55.1.3 upgrade
via GQL before upgradingto 8.12.1.

To upgrade to the 8.12.1 release from an 8.4.0 or later release:

Upgrade Process for Systems Running 8.4.0 and Later
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NOTE: Before upgrading, ensure that:
e Each SL1 Appliance has a valid license
e Each Data Collectoris a member of a Collector Group

o Each Data Collector is "available" to the Database Server. To check, see the Collector Status page
(System > Monitor > Collector Status).

NOTE: Staging and deploying SL1 patches is "hitless" and does not require a maintenance window.

1. Familiarize yourself with the Known Issues for this release.

2. Forsystems running an SL1 version priorto 8.12.0, go to the System Updates page and disable automatic
staging (System > Tools > Updates > Actions > Disable automatic staging).

« Ifyou have previously used manual staging, perform these additional steps:
o Goto the System Updates page (System > Tools > Updates). Select all updates in the EM7
Releases pane and select all updates in the Sciencelogic OS pane.
o In the Select Action menu, select Unstage Update (remove staging policy override). Click [Go].

o For software that was previously staged with automatic staging, Unstage Update (remove staging
policy override) does not affect staging.

NOTE: For details on downloading, importing, staging, and installing system updates, see the manual System
Administration.

3. Ifyou are currently running an 8.4 release:

o From the Sciencelogic portal, download the latest update for 8.5.0, 8.6.0, 8.7.0, 8.8.0, 8.9.0,
8.10.0,8.12.0, and 8.12.1 to a local computer. Unzip any zipped files.

e Importthe 8.5.0 system update file in the System Updates page (System > Tools > Updates >
[Import] button). The system update file will load an update in both the EM7 Releases and the
Sciencelogic OS section. You must wait until the update file has imported successfully (i.e. the Import
Status column displays Complete) before importing the next update file.
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Import the 8.6.0 system update file in the System Updates page (System > Tools > Updates >
[Import] button). The system update file will load an update in both the EM7 Releases and the
Sciencelogic OS section. You must wait until the update file has imported successfully (i.e. the Import
Status column displays Complete) before importing the next update file.

Importthe 8.7.0 system update file in the System Updates page (System > Tools > Updates >
[Import] button). The system update file will load an update in both the EM7 Releases and the
Sciencelogic OS section. You must wait until the update file has imported successfully (i.e. the Import
Status column displays Complete) before importing the next update file.

Import the 8.8.0 system update file in the System Updates page (System > Tools > Updates >
[Import] button). The system update file will load an update in both the EM7 Releases and the
Sciencelogic OS section. You must wait until the update file has imported successfully (i.e. the Import
Status column displays Complete) before importing the next update file.

Import the 8.9.0 system update file in the System Updates page (System > Tools > Updates >
[Import] button). The system update file will load an update in both the EM7 Releases and the
Sciencelogic OS section. You must wait until the update file has imported successfully (i.e. the Import
Status column displays Complete) before importing the next update file.

Import the 8.10.0 system update file in the System Updates page (System > Tools > Updates >
[Import] button). The system update file will load an update in both the EM7 Releases and the
Sciencelogic OS section. You must wait until the update file has imported successfully (i.e. the Import
Status column displays Complete) before importing the next update file.

Import the 8.12.0 system update file in the System Updates page (System > Tools > Updates >
[Import] button). You must wait until the update file has imported successfully (i.e. the Import Status
column displays Complete) before importing the next update file.

Gotostep #11 and continue.

4. Ifyou are currently running an 8.5 release:

From the Sciencelogic portal, download the latest update for 8.6.0, 8.7.0, 8.8.0, 8.9.0, 8.10.0,
8.12.0, and 8.12.1 to a local computer. Unzip any zipped files.

Import the 8.6.0 system update file in the System Updates page (System > Tools > Updates >
[Import] button). The system update file will load an update in both the EM7 Releases and the
Sciencelogic OS section. You must wait until the update file has imported successfully (i.e. the Import
Status column displays Complete) before importing the next update file.

Import the 8.7.0 system update file in the System Updates page (System > Tools > Updates >
[Import] button). The system update file will load an update in both the EM7 Releases and the
Sciencelogic OS section. You must wait until the update file has imported successfully (i.e. the Import
Status column displays Complete) before importing the next update file.

Import the 8.8.0 system update file in the System Updates page (System > Tools > Updates >
[Import] button). The system update file will load an update in both the EM7 Releases and the
Sciencelogic OS section. You must wait until the update file has imported successfully (i.e. the Import
Status column displays Complete) before importing the next update file.

Import the 8.9.0 system update file in the System Updates page (System > Tools > Updates >
[Import] button). The system update file will load an update in both the EM7 Releases and the
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Sciencelogic OS section. You must wait until the update file has imported successfully (i.e. the Import
Status column displays Complete) before importing the next update file.

Import the 8.10.0 system update file in the System Updates page (System > Tools > Updates >
[Import] button). The system update file will load an update in both the EM7 Releases and the
Sciencelogic OS section. You must wait until the update file has imported successfully (i.e. the Import
Status column displays Complete) before importing the next update file.

Import the 8.12.0 system update file in the System Updates page (System > Tools > Updates >
[Import] button). You must wait until the update file has imported successfully (i.e. the Import Status
column displays Complete) before importing the next update file. After 8.12.0 has been imported,
refresh the System Updates page to view the new user interface for the page.

Gotostep #11 and continue.

5. Ifyou are currently running an 8.6 release:

From the Sciencelogic portal, download the latest update for 8.7.0, 8.8.0, 8.9.0, 8.10.0, 8.12.0,
and 8.12.1 to a local computer. Unzip any zipped files.

Importthe 8.7.0 system update file in the System Updates page (System > Tools > Updates >
[Import] button). The system update file will load an update in both the EM7 Releases and the
Sciencelogic OS section. You must wait until the update file has imported successfully (i.e. the Import
Status column displays Complete) before importing the next update file.

Import the 8.8.0 system update file in the System Updates page (System > Tools > Updates >
[Import] button). The system update file will load an update in both the EM7 Releases and the
Sciencelogic OS section. You must wait until the update file has imported successfully (i.e. the Import
Status column displays Complete) before importing the next update file.

Import the 8.9.0 system update file in the System Updates page (System > Tools > Updates >
[Import] button). The system update file will load an update in both the EM7 Releases and the
Sciencelogic OS section. You must wait until the update file has imported successfully (i.e. the Import
Status column displays Complete) before importing the next update file.

Import the 8.10.0 system update file in the System Updates page (System > Tools > Updates >
[Import] button). The system update file will load an update in both the EM7 Releases and the
Sciencelogic OS section. You must wait until the update file has imported successfully (i.e. the Import
Status column displays Complete) before importing the next update file.

Import the 8.12.0 system update file in the System Updates page (System > Tools > Updates >
[Import] button). You must wait until the update file has imported successfully (i.e. the Import Status
column displays Complete) before importing the next update file. After 8.12.0 has been imported,
refresh the System Updates page to view the new user interface for the page.

Gotostep #11 and continue.
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6. Ifyou are currently running an 8.7 release:

From the Sciencelogic portal, download the 8.8.0, 8.9.0,8.10.0, 8.12.0, and 8.12.1 updates to a
local computer. Unzip any zipped files.

Import the 8.8.0 system update file in the System Updates page (System > Tools > Updates >
[Import] button). The system update file will load an update in both the EM7 Releases and the
Sciencelogic OS section. You must wait until the update file has imported successfully (i.e. the Import
Status column displays Complete) before importing the next update file.

Import the 8.9.0 system update file in the System Updates page (System > Tools > Updates >
[Import] button). The system update file will load an update in both the EM7 Releases and the
Sciencelogic OS section. You must wait until the update file has imported successfully (i.e. the Import
Status column displays Complete) before importing the next update file.

Import the 8.10.0 system update file in the System Updates page (System > Tools > Updates >
[Import] button). The system update file will load an update in both the EM7 Releases and the
Sciencelogic OS section. You must wait until the update file has imported successfully (i.e. the Import
Status column displays Complete) before importing the next update file.

Import the 8.12.0 system update file in the System Updates page (System > Tools > Updates >
[Import] button). You must wait until the update file has imported successfully (i.e. the Import Status
column displays Complete) before importing the next update file. After 8.12.0 has been imported,
refresh the System Updates page to view the new user interface for the page.

Continue tostep #11.

7. Ifyou are currently running an 8.8 release:

From the Sciencelogic portal, download the 8.9.0, 8.10.0, 8.12.0, and 8.12.1 updates to a local
computer. Unzip any zipped files.

Import the 8.9.0 system update file in the System Updates page (System > Tools > Updates >
[Import] button). The system update file will load an update in both the EM7 Releases and the
Sciencelogic OS section. You must wait until the update file has imported successfully (i.e. the Import
Status column displays Complete) before importing the next update file.

Import the 8.10.0 system update file in the System Updates page (System > Tools > Updates >
[Import] button). The system update file will load an update in both the EM7 Releases and the
Sciencelogic OS section. You must wait until the update file has imported successfully (i.e. the Import
Status column displays Complete) before importing the next update file.

Import the 8.12.0 system update file in the System Updates page (System > Tools > Updates >
[Import] button). You must wait until the update file has imported successfully (i.e. the Import Status
column displays Complete) before importing the next update file. After 8.12.0 has been imported,
refresh the System Updates page to view the new user interface for the page.

Gotostep #11 and continue.

8. Ifyou are currently running an 8.9 release:

From the Sciencelogic portal, download the 8.10.0, 8.12.0, and 8.12.1 updates to a local
computer. Unzip any zipped files.

Import the 8.10.0 system update file in the System Updates page (System > Tools > Updates >
[Import] button). The system update file will load an update in both the EM7 Releases and the
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Sciencelogic OS section. You must wait until the update file has imported successfully (i.e. the Import
Status column displays Complete) before importing the next update file.

e Import the 8.12.0 system update file in the System Updates page (System > Tools > Updates >
[Import] button). You must wait until the update file has imported successfully (i.e. the Import Status
column displays Complete) before importing the next update file. After 8.12.0 has been imported,
refresh the System Updates page to view the new user interface for the page.

e Gotostep #11 and continue.
9. Ifyou are currently running an 8.10 release:
o From the Sciencelogic portal, download the 8.21.0 and 8.12.1 updates to a local computer. Unzip

any zipped files.

e Importthe 8.12.0 system update file in the System Updates page (System > Tools > Updates >
[Import] button). You must wait until the update file has imported successfully (i.e. the Import Status
column displays Complete) before importing the next update file. After 8.12.0 has been imported,
refresh the System Updates page to view the new user interface for the page.

e Gotostep #11 and continue.
10. Ifyou are currently running the 8.12.0 release or an 8.12.0.x release:
o From the Sciencelogic portal, download the 8.12.1 update to a local computer. Unzip any zipped

files.

e Gotostep #11 and continue.

11. Importthe 8.12.1 system update file in the System Updates page (System > Tools > Updates > [Import]
button).

12. Selectthe staging icon (@) for8.12.1.

13. When staging has completed, select the lightning-bolt icon (# ) to deploy 8.12.1.
14. Clearyour browser's cache.
15. Clearthe SL1 cache.

o Gotothe Cache Management page (System > Tools > Cache).

o From the hamburger menu ( — ), select Clear EM7 System Cache.

An update in 8.12.1 requires that you clear the EM7 System Cache. Until you clear the EM7
System Cache, you might experience errors with credentials that can affect discovery, calls to the
the Sciencelogic API, and calls to GQL.

17. Ifyou have not previously upgraded to 8.2.0, perform the steps listed in the Other Manual Updates
section.

18. Gotothe PowerPack Manager page (System > Manage > PowerPacks) and install all updated
PowerPacks. Updated PowerPacks are loaded on your Sciencelogic system by the patch process. To install
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an updated PowerPack, find the PowerPack in the PowerPack Manager page and select the installation

icon (# ) in the Update column for the PowerPack or use the Update PowerPacks option in the Select
Action drop-down list.

TIP: By default, installing an updated version of a PowerPack will overwrite all content in that PowerPack that
has already been installed on the target system. You can use the Enable Selective PowerPack Field

Protection setting in the Behavior Settings page (System > Settings > Behavior) to prevent new
PowerPacks from overwriting local changes for some commonly customized fields.

19. Ifyou are monitoring devices using the Sciencelogic Agent, follow the steps listed in the Agent Monitoring
manual to upgrade to the latest version of the Agent.

Upgrading MariaDB and the rebooting all SLT appliances should be performed during a
maintenance window. If you would like assistance in planning an upgrade path that minimizes
downtime, please contact your Customer Success Manager.

20. Upgrade MariaDB to the latest version. To do so, perform the steps in the Upgrading MariaDB section.

21. 8.12.1 includes important security updates that require you to reboot all appliances after installing
8.12.1. lf you would like assistance in planning an upgrade path that meets your security needs while
minimizing downtime, please contact your Customer Success Manager.

Upgrading MariaDB

Version 8.12.0 requires updates to MariaDB that address security and performance issues. You can download the
latest approved MariaDB updates at https://portal.sciencelogic.com/portal/miscellaneous.

NOTE: To address security issues, download the latest MariaDB updates. Earlier MariaDB updates remain on
the portal fo support users who have not yet migrated to the latest release.

The following sections describe how to perform this upgrade for different appliance types and architectures.
Two Database Servers Configured for High Availability

To upgrade a High Availability cluster, perform the following steps:

WARNING: The system will be unavailable when performing these steps.

1. Copy the MariaDB RPMs to the file system of both appliances.
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10.

11.

12.

13.

14.

15.

Log in to the command-line of both Database Server appliances as em7admin.

Execute the following command on the secondary Database Server:

sudo systemctl stop pacemaker.service

Execute the following command on the primary Database Server to determine the current installed version of
the RPMs:

sudo rpm -ga “MariaDB-*

Execute the following command on the primary Database Server:

sudo systemctl stop mysqgl

On the primary Database Server, navigate to the directory that you copied the RPMs.

For each RPM that the output from step 5 showed at an earlier version, execute the following command on
the primary Database Server:

sudo rpm -Uvh <file name of RPM>

Execute the following command on the primary Database Server to validate that the RPMs installed correctly:

sudo rpm -ga “MariaDB-*

Execute the following command on the primary Database Server:

sudo systemctl start mysql

Execute the following command on the primary Database Server, replacing the password for the root
database user when prompted:

sudo mysgl upgrade -u root -p

On the secondary Database Server, execute the following command to determine the current installed
version of the RPMs:

sudo rpm -ga “MariaDB-*
On the secondary Database Server, navigate to the directory where you copied the RPMs.

For each RPM that the output from step 11 showed at an earlier version of MariaDB, execute the following
command on the secondary Database Server:

sudo rpm -Uvh <file name of RPM>

Execute the following command on the secondary Database Server to validate that the RPMs installed
correctly:

sudo rpm -ga “MariaDB-*

Execute the following command on the secondary Database Server:

sudo systemctl start pacemaker.service
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Two Database Servers Configured for Disaster Recovery

To upgrade two Database Servers configured for disaster recovery, perform the following steps:

WARNING: The system will be unavailable when performing these steps.

10.

11.
12.

13.

Copy the latest RPMs 1o the file system of both appliances.
Log in to the command-line of both Database Server appliances as em7admin.

Execute the following command on the primary Database Server to determine the current installed version of
the RPMs:

sudo rpm -ga “MariaDB-*

Execute the following command on the primary Database Server:

sudo systemctl stop mysqgl

On the primary Database Server, navigate to the directory that you copied the RPMs.

For each RPM that the output from step 4 showed at an earlier version, execute the following command on
the primary Database Server:

sudo rpm -Uvh <file name of RPM>

Execute the following command on the primary Database Server to validate that the RPMs installed correctly:

sudo rpm -ga “MariaDB-*

Execute the following command on the primary Database Server:

sudo resource start mysqgl

Execute the following command on the primary Database Server, replacing the password for the root
database user where indicated:

sudo mysgl upgrade -u root -p
On the secondary Database Server, execute the following command to determine the current installed

version of the RPMs:

sudo rpm -ga “MariaDB-*

On the secondary Database Server, navigate to the directory where you copied the RPMs.

For each RPM that the output from step 10 showed at an earlier version, execute the following command on
the secondary Database Server:

sudo rpm -Uvh <file name of RPM>

Execute the following command on the secondary Database Server to validate that the RPMs installed
correctly:

sudo rpm -ga “MariaDB-*
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Three Database Servers Configured for HA and DR

To upgrade a High Availability cluster, perform the following steps:

WARNING: The system will be unavailable when performing these steps.

10.

11.

12.
13.

Copy the latest RPMs to the file system of all three appliances.
Log in to the command-line of all three Database Server appliances as em7admin.

Execute the following command on the secondary Database Server in the HA cluster:

sudo systemctl stop pacemaker.service

Execute the following command on the primary Database Server in the HA cluster to determine the current
installed version of the RPMs:

sudo rpm -ga “MariaDB-*

Execute the following command on the primary Database Server in the HA cluster:

sudo systemctl stop mysqgl

On the primary Database Server in the HA cluster, navigate to the directory that you copied the RPMs.

For each RPM that the output from step 5 showed at an earlier version, execute the following command on
the primary Database Server in the HA cluster:

sudo rpm -Uvh <file name of RPM>

Execute the following command on the primary Database Server in the HA cluster to validate that the RPMs
installed correctly:

sudo rpm -ga “MariaDB-*

Execute the following command on the primary Database Server in the HA cluster:

sudo systemctl start mysql

Execute the following command on the primary Database Server in the HA cluster, replacing the password for
the root database user where indicated:

sudo mysgl upgrade -u root -p
On the secondary Database Server, execute the following command to determine the current installed

version of the RPMs:

sudo rpm -ga "MariaDB-*

On the secondary Database Server, navigate to the directory where you copied the RPMs.

For each RPM that the output from step 11 showed at an earlier version, execute the following command on
the secondary Database Server:

sudo rpm -Uvh <file name of RPM>
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14.

15.

16.

17.
18.

19.

20.

Execute the following command on the secondary Database Server in the HA cluster o validate that the RPMs
installed correctly:

sudo rpm -ga “MariaDB-*

Execute the following command on the secondary Database Server in the HA cluster:

sudo systemctl start pacemaker.service

On the Database Server for disaster recovery, execute the following command to determine the current
installed version of the RPMs:

sudo rpm -ga “MariaDB-*

On the Database Server for disaster recovery, navigate to the directory that you copied the RPMs.

For each RPM that the output from step 16 showed at an earlier version, execute the following command on
the Database Server for disaster recovery:

sudo rpm -Uvh <file name of RPM>

Execute the following command on the secondary Database Server in the HA cluster to validate that the RPMs
installed correctly:

sudo rpm -ga “MariaDB-*

Execute the following command on the Database Server for disaster recovery fo validate that the RPMs
installed correctly:

sudo rpm -ga “MariaDB-*

Single Database Server/All-In-One Appliance/Data
Collector/Message Collector

To upgrade MariaDB on a single Database Server, All-In-One Appliance, Data Collector, or Message Collector,
perform the following steps:

WARNING: The Database Server, All-In-One Appliance, Data Collector, or Message Collector will be

inoperable when performing these steps.

Copy the latest RPMs 1o the file system of the appliance:
Log in to the command-line of the appliance as em7admin.

Execute the following commands:

sudo systemctl stop em7
sudo systemctl stop mariadb.service

Execute the following command to defermine the current installed version of the RPMs:

sudo rpm -ga "MariaDB-*

Navigate to the directory that you copied the RPMs.

For each RPM that the output from step 4 showed at an earlier version, execute the following command:
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sudo rpm -Uvh <file name of RPM>

7. Execute the following command to validate that the RPMs installed correctly:

sudo rpm -ga “MariaDB-*

8. Execute the following commands:
sudo systemctl daemon-reload
sudo systemctl start mariadb.service

9. Execute the following command, replacing the password for the root database user where indicated:

sudo mysgl upgrade -u root -p

10. Execute the following command to re-start SL1:

sudo systemctl start em7

Manual Updates for 8.4.x Systems Updated to 8.12.0

If you upgraded from an 8.4 .x system 10 8.12.0, after 8.12.0 is installed, you must manually apply the following
changes to every Message Collector and All-In-One Appliance in your system:

1. Either go to the console or use SSH to access the server.

2. Login as userem7admin with the appropriate password.

3. Enterthe following at the command line:

sudo vi /etc/siteconfig/siloconf.siteconfig

4. Locate the following line:

eventmanager = syslog, trap,internal

NOTE: On an All-In-One Appliance, this line will include additional entries in the comma-delimited
list.

5. Add",agent"tothe end of the line. The line should now look like this:

eventmanager = syslog, trap,internal, agent

6. Save the file and exit vi (:wq).

7. Atthe command line, enter the following command to rebuild the configuration file:

sudo /opt/em7/share/scripts/generate-silo-conf.py > /etc/silo.conf

Rebooting Appliances

Use the applicable steps listed in this section fo reboot your appliances.
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Administration Portal

If your SL1 system includes multiple Administration Portals, you can remotely reboot Administration Portals from
another Administration Portal. To do so:

1. Gotothe Appliance Manager page (System > Seftings > Appliances).

2. Selectthe checkboxes for the appliances you want to reboot.

3. Inthe [Select Action] menu, select Reboot and click the Go button.

4. Click the OK button when the "Are you sure you want to reboot the selected appliancese" message is
displayed.

5. During the reboot, the user interface for the affected Administration Portals is unavailable.

When the reboot has completed, the Audit Logs page (System > Monitor > Audit Logs) will include an entry
for each appliance that was rebooted.

Ifyour SL1 system include only a single Administration Portal, perform the following steps to reboot that
Administration Portal:

1. Either go to the console of the Database Server or use SSH to access the server.

2. Log in as em7admin with the appropriate password.

3. Atthe shell prompt, execute the following:

python -m silo common.admin toolbox <appliance ID> "/usr/bin/sudo /usr/sbin/shutdown
- +1"

where:

o appliance_ID is the appliance ID for the Data Collector, Message Collector, or Administration Portal.

Data Collectors and Message Collectors

You can reboot Data Collector and Message Collectors either from the user interface or from the command line.
From the SL1 user interface, perform the following steps to reboot a Data Collector or Message Collector:

1. Gotothe Appliance Manager page (System > Seftings > Appliances).
2. Selectthe checkboxes for the appliances you want to reboot.

3. Inthe [Select Action] menu, select Reboot and click the Go button.

4

Click the OK button when the "Are you sure you want to reboot the selected appliances?" message is
displayed.

5. During the reboot, go to the System Logs page (System > Monitor > System Logs). You should see this
message:

Major: Could not connect to module (5) database USING SSL=TRUE: Error attempting
to connect to database with SSL enabled True: (2003, 'Can't connect to MySQL
server on '10.2.12.77' (113 "No route to host™)')
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6. When the reboot has completed, the Audit Logs page (System > Monitor > Audit Logs) will include an entry
for each appliance that was rebooted.

From the console of the Database Server or SSH 1o the Database Server, perform the following steps to reboot a
Data Collector or Message Collector:

1. Either goto the console of a Database Server or SSH to access the server.
2. Login asem7admin with the appropriate password.

3. Atthe shell prompt, execute the following:

python -m silo common.admin toolbox <appliance ID> "/usr/bin/sudo /usr/sbin/shutdown
-r +1"

where:

« appliance_ID is the appliance ID for the Data Collector, Message Collector, or Administration Portal.

Standalone All-In-One Appliances and Database Servers

Perform the following steps to reboot a standalone All-In-One Appliance or Database Server:

1. Either goto the console or use SSH to access the server.
2. Login asem7admin with the appropriate password.

3. Execute the following commands on the appliance to pause the system and shutdown MariaDB. Enter the
password for the em7admin user when prompted:

sudo touch /tmp/.proc mgr pause
sudo systemctl stop mariadb

4. Execute the following command on the appliance to reboot the appliance:

sudo reboot

5. After the appliance has rebooted, log in to the appliance as the em7admin user using the console or SSH.

6. Execute the following command on the appliance to un-pause the system:

sudo rm /tmp/.proc _mgr pause

7. Enterthe password for the em7admin user and confirm the command when prompted.

Two Database Servers Configured for Disaster Recovery

Perform the following steps to reboot two Database Servers configured for Disaster Recovery:

1. Either go fo the console of the primary Database Server or use SSH to access the server.
2. Login asem7admin with the appropriate password.

3. First, you should check the status of the appliances. To do this, enter the following at the shell prompt:

cat /proc/drbd
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4.

10.
11.

12.

Your output will look like this:

1: cs:Connected ro:Primary/Secondary ds:UpToDate/UpToDate C r—----—
ns:17567744 al:0 bm:1072 10:0 pe:0 ua:0 ap:0 ep:1 wo:b 00s:12521012

NOTE: If your output includes "ro:Primary/Secondary", but does not include "UpToDate/UpToDate",
data is being synchronized between the two appliances. You must wait until data
synchronization has finished before rebooting.

Execute the following commands on the primary appliance to pause the system and shutdown MariaDB.

Enter the password for the em7admin user when prompted:

sudo touch /tmp/.proc mgr pause
sudo systemctl stop pacemaker

Execute the following command on the primary appliance to reboot the appliance:

sudo reboot

After the primary appliance has rebooted, log in to the console of the primary appliance again.

Execute the following commands on the primary appliance:

sudo rm /tmp/.proc mgr pause

Enter the password for the em7admin user and confirm the command when prompted.
Log in to the secondary Database Server as the em7admin user using the console or SSH.

Execute the following command on the secondary appliance to reboot the appliance:

sudo reboot

Enter the password for the em7admin user when prompted.
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Two Database Servers in a High Availability Cluster

Perform the following steps to reboot two Database Servers in a high availability cluster:

1. Either goto the console of the secondary Database Server or use SSH 1o access the server.
2. Login as em7admin with the appropriate password.

3. First, you should check the status of the appliances. To do this, enter the following at the shell prompt:

cat /proc/drbd

4. Your output will look like this:

1: cs:Connected ro:Secondary/Primary ds:UpToDate/UpToDate C r—---—
ns:17567744 al:0 bm:1072 10:0 pe:0 ua:0 ap:0 ep:1 wo:b 00s:12521012

NOTE: If your output includes "ro:Secondary/Primary", but does not include "UpToDate/UpToDate", data is
being synchronized between the two appliances. You must wait until data synchronization has finished
before rebooting.

5. Execute the following command on the secondary appliance to stop the cluster service:

sudo systemctl stop pacemaker

6. Enterthe password for the em7admin user when prompted.
7. Loginto the primary Database Server as the em7admin user using the console or SSH.

8. Execute the following commands on the primary appliance to pause the system and stop the cluster service.
Enter the password for the em7admin user when prompted:

sudo touch /tmp/.proc mgr pause
sudo systemctl stop pacemaker

9. Execute the following command on the primary appliance to reboot the appliance:

sudo reboot
10. After the primary appliance has rebooted, log in to the console of the primary appliance again.

11. Execute the following command on the primary appliance:

sudo rm /tmp/.proc _mgr pause

12. Enterthe password for the em7admin user and confirm the command when prompted.

13. Ensure thatthe user interface is now available on the primary appliance.

14. Login to the secondary Database Server as the em7admin user using the console or SSH.

15. Execute the following command on the secondary appliance to reboot the appliance:

sudo reboot

16. Enterthe password forthe em7admin user when prompted.
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Three Database Servers Configured for High Availability and Disaster
Recovery

Perform the following steps to reboot three Database Servers configured for high availability and disaster recovery:

1. Either goto the console of the secondary Database Server in the HA cluster or use SSH 1o access the
server.

2. Login asem7admin with the appropriate password.

3. First, you should check the status of the appliances. To do this, enter the following at the shell prompt:
cat /proc/drbd

4. Your output will look like this:

10: cs:Connected ro:Secondary/Primary ds:UpToDate/UpToDate C r--—--
ns:17567744 al:0 bm:1072 10:0 pe:0 ua:0 ap:0 ep:1 wo:b 00s:12521012

NOTE: If your output includes "ro:Secondary/Primary", but does not include "UpToDate/UpToDate", data is

being synchronized between the two appliances. You must wait until data synchronization has finished
before rebooting.

10.

11.

12.
13.

14.

Execute the following command on the secondary Database Server in the HA cluster to stop the cluster
service:

sudo systemctl stop pacemaker

Enter the password for the em7admin user when prompted.
Log in to primary Database Server as the em7admin user using the console or SSH.

Execute the following commands on the primary appliance to pause the system and stop the cluster service.
Enter the password for the em7admin user when prompted:

sudo touch /tmp/.proc mgr pause
sudo systemctl stop pacemaker

Execute the following command on the primary appliance to reboot the appliance:

sudo reboot
After the primary appliance has rebooted, log in to the console of the primary appliance again.

Execute the following command on the primary appliance:

sudo rm /tmp/.proc _mgr pause

Enter the password for the em7admin user and confirm the command when prompted.

Log in to the secondary Database Server in the HA cluster as the em7admin user using the console or

SSH.

Execute the following command on the secondary Database Server in the HA cluster to reboot the
appliance:
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sudo reboot

15. Enterthe password for the em7admin user when prompted.

16. Log in to the Database Server for Disaster Recovery as the em7admin user using the console or SSH.

17. Execute the following command on the Database Server for Disaster Recovery to reboot the appliance:

sudo reboot

18. Enterthe password for the em7admin user when prompted.

Deprecated Features

As ofthe 8.2.0 release, the following PowerPacks are no longer included in the default ISO. These PowerPacks
will not be automatically removed from an existing system during an upgrade and will remain available for
download on the Sciencelogic Portal:

o ADIC Base Pack

o Ascend Communications Base Pack

o Cabletron System Base Pack

o CloudKick Management

o GoGrid Base Pack

o Informant Cluster

o Informant Exchange

o Informant MS SQL

o Informant Windows OS

o NTIBase Pack

o Rackspace Base Pack

o Redback Base Pack

o RIM Blackberry Base Pack

« Sensatronics Base Pack

o SystemEdge Base Pack

o System Uptime

« Tipping Point Base Pack

o Xirrus Base Pack
The new user interface architecture requires APl access for all users; APl access is automatically granted to users.
The following API-specific access hooks have been deprecated and removed from the product:

o API: Resource Indexes

o API: Server Access

o API: Virtual Device
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The following functionality that was available in previous releases is no longer available in the 8.12.1 release:

o The process for generating rollup/normalized data has been updated to improve performance and
scalability. This update deprecates the generation of frequent rollup data. The following user interface pages
are affected:

o The widgets Leaderboard/Top-N, Leaderboard/Top-N (secondary), and Multi-Series Performance no
longer support Frequent normalization. If these widgets are used by older dashboards and are already
configured o use Frequent normalization, the platform will automatically update these widgets to use
hourly normalization.

o Inthe Collection Labels page (System > Manage > Collection Labels), the Frequent Data column is
deprecated.

o The Cisco Nexus PowerPack has been removed from the default build and is no longer supported. However,
the PowerPack is not deleted during the upgrade process. The device classes for Cisco Nexus devices are
now included in the Cisco: Base Pack PowerPack.

o The Sciencelogic Agent no longer supports 32-bit versions of Linux or Windows.
o The third-party Azure python library has been removed from the ISO build.
o The FTP, SFTP, NFS, and SMB backup options that stage locally are no longer supported.

o The EMC Base Pack PowerPack has been removed from the default build and is no longer supported.
However, the PowerPack is not deleted during the upgrade process. If you are still using the EMC Base Pack
PowerPack, Sciencelogic recommends using the EMC: VNX PowerPack instead.

o The SAN wizard is no longer supported. Sciencelogic will no longer provide direct support for configuring a
SAN for data storage.

« Integration Server appliances are no longer supported.
o Root access is not enabled on any appliance.
o The VMware: vCloud PowerPack has been removed from the ISO build and is no longer supported.

o The "ifconfig" command is no longer supported by the new appliance operating system. The "ip addr"
command must be used instead.

o NOC Screens (System > Manage > Screens) are no longer included in the platform. To re-enable this
feature, contact Sciencelogic Customer Support.

« The Knowledge Base is no longer supported by Sciencelogic and will be disabled by default for new users.

« High-Availability and Disaster Recovery no longer support the command "drbd-overview". To check the status

of drbd, use "cat /proc/drbd".
« System Update no longer supports the shell command "deploy patch".

Known Issues

For a list of Known Issues and workarounds, see the SciencelLogic Cusotmer Portal at

https://support.sciencelogic.com/s/topic/0TO0z000000E6w7 GAC /known-issues.
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