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Overview

Overview

This document describes:

l Caveats

l Best Practices

l The New Features in the 8.12.2 release

l The Issues Addressed in the 8.12.2 release

l New and Updated Packages in the 8.12.2 release

l The Beta Features available with the 8.12.2 release

l Disabling the Knowledge Base

l Special Upgrade Process for FIPS-Compliant Systems

l Upgrade Process for Systems Running 8.1.0 and Earlier

l Upgrade Process for Systems Running 8.4.0 and Later

l Manual Updates for 8.4.x Systems Updated to 8.12.2

l Upgrading MariaDB

l Rebooting Appliances

l The features deprecated in this release

l The Known Issues

TIP: 8.12.2 includes delta-less updates. If you have already deployed 8.6.0 or later, you can import, stage,
and deploy a single update file to update to 8.12.2.

Caveats

Consider the following caveats before deploying 8.12.2:

l As of 8.12.2, ScienceLogic will no longer update the help that appears when you select the [Guide] button.
The Unified UI provides a new tool for inline help. Under the user name in the upper right corner, click the
down arrow and select Help. The browser will spawn a new window that displays the appropriate page from
docs.sciencelogic.com.

l SL1 updates overwrite changes to the configuration file opt/em7/nextui/nextui.env. This is a known
issue (see https://support.sciencelogic.com/s/article/1161 and
https://support.sciencelogic.com/s/article/1423). ScienceLogic recommends that you backup this file before
applying an update and then re-apply your changes to this file.
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Best Practices

l Do not import any releases from the 8.12.x line if you do not plan to immediately consume the
8.12.x line of releases. After you import an 8.12.x release, all appliances in your SL1 system will now use
the new system update. After you import an 8.12.x release, you will not be able to stage and deploy any
versions of SL1 previous to 8.12.0 or apply patches to versions of SL1 previous to 8.12.0. For details on the
new system update, see the release notes for 8.12.0.

l To install 8.12.x and its new SystemUpdates tool, you have must have already imported, staged,
and deployed 8.4.0 or a later release.

l 8.12.1 included important security updates that require you to reboot all appliances after installing 8.12.1. If
you have not previously installed 8.12.1 and rebooted all appliances, you must reboot all
appliances after installing 8.12.2.If you would like assistance in planning an upgrade path that meets your
security needs while minimizing downtime, please contact your Customer Success Manager.

l 8.10.0 and later releases do not support Data Collectors and Message Collectors running the CentOS
operating system. If your system includes Data Collectors and Message Collectors running the CentOS
operating system, contact your Customer Success Manager for details on upgrading Data
Collectors and Message Collectors to Oracle Linux before installing 8.12.2.

l The Knowledge Base includes known vulnerabilities for cross-site scripting and SQL injection. If your first
installation of SL1 was 8.9.1 or earlier, ScienceLogic strongly recommends that youdisable the
Knowledge Base.

l If you are running 8.4.0 or earlier and require access to all ticket notes immediately after upgrading, contact
ScienceLogic Customer Support for details on manually updating the database schema before you upgrade.

l If you are running 8.4.0 or earlier and have added one or more custom firewall rules, such as a non-
standard port for Phone Home Collectors, you must migrate these rules to firewalld before upgrading. Please
contact ScienceLogic Support for more information.

l ScienceLogic recommends that Systems running an AP2 version earlier than 5.55.1.3 upgrade their version
of AP2 before upgrading to 8.12.2. For details, see the manual Introduction to SL1, section onManaging
New Features on the Content Management Page.

l During the normal system update process, multiple processes are stopped and restarted. This might result in
missed polls, gaps in data, and/or unexpected errors. ScienceLogic recommends that you always install
ScienceLogic releases during a maintenance window.

l The ScienceLogic system update process starts a background process that can perform any required post-
upgrade tasks. The post-patch update process is automatically stopped after 24 hours. However, depending
on the size of your database as well as the version from which you are upgrading, the post-upgrade tasks can
take several days to perform. If the post-patch update process is stopped after 24 hours, the process will
automatically re-start and continue processing from the point at which it was stopped. If you see an event that
indicates the post-patch update process was stopped, you do not need to contact ScienceLogic support for
assistance until you see the same event for three consecutive days.

Best Practices

Consider the following best practices before deploying 8.12.2:

l Before you install a ScienceLogic release, ScienceLogic recommends reviewing the hardware specifications
of all the appliances in your system to ensure they meet the requirements for the current usage of your system.
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New Features in 8.12.2

For more information, see https://support.sciencelogic.com/s/system-requirements.

l Before installing a release, ScienceLogic recommends that you verify that recent backups are available for
your system.

l To apply updates to an existing Data Collector, that Data Collector must be a member of a Collector Group.
In some SL1 systems, users might have to create a Collector Group for a single Data Collector.

l If your system is not currently running a recent release, the upgrade process includes importing multiple
upgrade files. You must wait until an update file has imported successfully (i.e. the Import Status column
displays Complete in both the EM7 Release pane and the ScienceLogic OS pane) before importing the next
update file.

l ScienceLogic regularly uploads new and updated PowerPacks to the Customer Portal before packaging
those PowerPacks in a system update file. For more information, see
https://portal.sciencelogic.com/portal/powerpacks.

New Features in 8.12.2

NOTE: The Unified UI includes pages from the SL1 Classic UI that have been ported to the SL1 Next UI and
pages developed in the Next UI.

AP2

l SL1 8.12.2 includes the following version of the unified user interface:

o AP2 5.149.14

Business Services

l The Service Investigator page for a Device Service now includes an Info drop-down that displays
additional information about the device service, including the owner, contact organization, description, and
the Include devices from visible organizations option.

l You can now use metrics collected by the SL1 Agent when editing the conditions for a device service policy.
The metrics are available on the Collection Labels section of the Property drop-down of the Edit Condition
page.

Custom Attributes
l The Custom Attributes page (Manage > Custom Attributes) lets you create and edit system-wide

descriptive fields for assets, services, interfaces, themes, and vendors in SL1.

Dashboards

l The following attributes have been added to the Device Table and Device Leaderboard widgets:
Collector/Group, Device Class, Device Category, Device Type, Uptime, and Last Poll.

l Events Leaderboard Bar Charts can now publish multiple contexts at the same time, such as devices and
services. Previously, you could only publish one type of context.
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New Features in 8.12.2

l You can choose to display or hide the Device Name and Index Label in a bar chart, and you can also edit the
device name or index name.

l You can choose to display device icons in a Leaderboard or Table widget. You can also choose to display
service icons in a Leaderboard or Table widget.

l The new Sunburst dashboard widget lets you view Business Services in a Sunburst chart, so that you can see
the status of Business Services, IT Services, Device Services, and (where relevant) devices in the three
different rings.

l For a Service Tile widget, you can select the "Automatically adjust tile size based on widget height" option, or
you can toggle that off and choose from "Full" or "Compact" tile size options.

l You can use the Auto Selection option for Events widgets.

l The Show Trend option in the Number widget was removed from event count metrics.

l Updates to printed and exported dashboards. The Limit Decimal Places option lets you specify how many
decimal places you want to see in the data of an exported dashboard. The default is two decimal places.
Also, the default layout for an exported dashboard is now set to "Landscape". For exported dashboards, the
values for Age, Severity, Health, and Availability display in a manner consistent with the user interface.

Devices

l The [Attributes] tab is now available on Device Investigator pages. On the [Attributes] tab, you can add
and remove Custom Attributes, which are managed on the Custom Attributes page (Manage > Custom
Attributes). You can also edit the value for a custom attribute on the [Attributes] tab.

l The [Collections] tab on Device Investigator pages contains a list of collection objects for the Dynamic
Applications aligned with that device. On this tab, you can change the Poll Frequency for a Dynamic
Application. You can also view the presentation objects for aligned Dynamic Applications.

l The [Collections] tab has a Run Dynamic App column with a Run Now button that you can click to run that
Dynamic Application immediately. The sidebar that appears when you select a Dynamic Application has an
Actions button with a Run Now option as well.

l On the [Collections] tab, you can view new icons to quickly determine the status of the collection objects
and presentation objects in a Dynamic Application. You can also click the name of an object on this tab to
view more information about the collection objects and presentation objects that are aligned to the device. .
In addition, you can choose to enable or disable collection for a collection object in a Dynamic Application
aligned with the device.

l On the [Collections] tab, you can view and edit the credential for Dynamic Application aligned with the
device.

l The tables on the [Configs] tab on Device Investigator pages were updated to make them more readable.

l On the [Events] tab for a device, the following options were added to the [Actions]menus: Create Ticket,
View Event Policy, and Suppress Event for this Device. Also, the following columns were added to the list of
events: Ticket External Reference, Event Source, and Last Detected.

l The [Software] tab for a device was updated to match the look and feel of the Unified user interface.

Discovery

l In addition to Amazon Web Services, the Guided Discovery workflow includes new buttons for the following
discovery types: Alibaba Cloud, Microsoft Azure, Citrix, and IBM Cloud.

Dynamic Applications
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New Features in 8.12.2

l ICDA Dynamic Applications that are cache producers or cache consumer now successfully collect data from
merged devices.

Events

l The new Event Policies page (Events > Event Policies in the Unified user interface) lets you view all available
event policies. On this page, you can also edit, enable, or disable event policies.

l You can view the event policy that generated that event by selecting View Event Policy from the Actions
menu on the Events page.

l You can add a device to the list of suppressions so you no longer see that event for that event policy for that
device by selecting Suppress Event for this Device from the Actionsmenu on the Events page.

l From the Events page, you can selectGroup by business service from the View drop-down to group events
generated from Business Services, including events from its IT Services and their Device Services, and events
from the underlying devices..

l When grouping events by business service, events from child or constituent services will also appear in the
list.

l From an Event Investigator page, you can click the name of an aligned device or service to go to the detail
page for that device or service. You can also click the name of the aligned organization to view its
Organizational Summary page.

Maps

l You can use the Add Node button to search for and add a node to an existing map.

l The new interactive legend is available from the left-hand side of a map window. When you select a node on
the map with the legend open, the legend shows a close-up of that node and its immediate connections.
Select another node to see details for that node.

l On the Settings > Design pane for a map, you can toggle the Show Details on Hover option to enable or
disable the pop-up Properties pane that appears when you hover over a node in the map.

l The appearance of the arrowhead edges was updated, and you can use the Arrow Spacing Ratio option on
the Settings > Design pane to change the space between the arrowheads and the nodes in a map.

l You can add an .SVG image as a background to a map.

l If you want to use maps on another SL1 system, you can package maps into a PowerPack and export them to
the other SL1 system.

l TheMapsmanual includes a new Troubleshooting chapter.

Search

l The search results and search criteria fields under the Search field were minimized to keep them from
covering the content below the search area. Also, the search criteria button under the Search field now
displays the field and value for the search as hover text.

l If you click the menu icon to the right of the Search field for a device, you can use the "Class" filter from the
initial menu. Previous this filter was available as a sub-category under the "deviceClass" filter, and it was
called "logicalName".

Security
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Issues Addressed in 8.12.2

l 8.12.2 includes multiple package updates to address security issues.

Themes

l The new Theme Settings page lets you set the primary and secondary colors for the current user in the SL1
user interface. You can also set the colors for the navigation bar and the left-hand menu and upload a .SVG
image for the site logo. To access the Theme Settings page, click your user name in the navigation bar in
the top-right corner of any SL1 page and select Settings.

Issues Addressed in 8.12.2

NOTE: The Unified UI includes pages from the SL1 Classic UI that have been ported to the SL1 Next UI and
pages developed in the Next UI.

Authentication

l During SSO login, users no longer experience a redirect loop when authenticating against their IdP. (Support
ID: 179556) (Case 43525)

l Users can now authenticate and access SL1 from a Database Server in a clustered environment. (Support ID:
1809170) (Case 49753)

Business Services

l Addressed an issue where a user could not create a Business Service from a template after upgrading to ap2
version 5.125.44. (Support ID: 179159)(case 00042492)

Dashboards

l Addressed an issue where the Service Widget for Line Charts was only using hourly roll-up data, and the
dashboard generated an error if you selected raw data. (Support ID: 181704)(case 00052282)

Devices

l In the Device Investigator page, in the Logs pane, theMessage column no longer truncates log
entries. Also, hovertext is available for all columns in the Logs pane.

l In the unified user interface, in Devices > Interfaces, the Admin Status and the Operational Status are no
longer inverted. (Support ID: 181173) (Case 50460)

l Addressed an issue on the Device Investigator page where text was cut off in theMessage column of a log
aligned with that device. Also, hovertext is available for all columns in the Logs table on these pages.
(Support ID: 178782)(case 00035579)

Events

l On the Events page, addressed an issue where Applications and Application Components displayed as
"Unknown" in the Type column if you selectedGroup by business service from the Viewmenu.

GraphQL
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New and Updated Packages in 8.12.2

l To improve performance, "DynamicApplicationPresentation" has been removed as a top-level resource in
GQL.

Maps

l Maps were updated to prevent curved edges from overlapping.

l Addressed an issue with some maps with a forced layout where the nodes continued moving or "jittering",
usually after you expanded one or more nodes on the map.

Network Interfaces

l Addressed an issue with network interface. The unified UI and the classic UI no longer display conflicting
Admin status and Operational status for the same network interface. (Support ID: 181167) (Case 50627)

l Addressed an issue with network interfaces. In the classic UI, updated the Interface Details tooltip (Registry >
Devices > wrench icon > Interfaces tab > hover) to display the correct Admin Status and Operational Status.
(Support ID: 181167) (Case 50627)

New and Updated Packages in 8.12.2

8.12.2 includes multiple package updates to address security issues.

WARNING: 8.12.2 includes important security updates that require you to reboot all appliances
after installing 8.12.2. If you would like assistance in planning an upgrade path that meets your
security needs while minimizing downtime, please contact your Customer Success Manager.

Beta Features

The following beta features are included in the 8.12.2 release:

l Manual Device Discovery

o This beta feature allows monitored devices to be added manually instead of via a discovery session.

l Run Book Actions: Custom Action Type

l A Run Book Action of type "Custom Action Type" executes a reusable snippet. Unlike the Action Type
"Snippet", a Custom Action Type can accept input parameters (in a JSON format) and create output
(in a JSON format). A Custom Action Type allows a single snippet to be used in multiple Action
Policies, each time with different inputs and different outputs. A Custom Action Type is associated with
an Execution Environment. An Execution Environment contains the supporting modules and code
(Content Libraries) required by the Custom Action Type. Content Libraries allow snippet developers to
isolate the “heavy weight”, re-usable code and write “light weight” snippets that call the Content
Libraries.
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Beta Features

l PowerPacks: Beta versions of the following PowerPacks are available. You can download then from the
Customer Portal and import them into SL1:

o Alibaba Cloud: Aliyun

o AMQP: RabbitMQ

o Cisco: ACI Multi-Site Manager

o Cisco: Cloud Center

o Cisco: Contact Center Enterprise

o Cisco: Hyperflex

o Cisco: Medianet/Mediatrace

o Cisco: Meraki (API)

o Cisco: Tetration

o Cisco: UC Ancillary PowerPack. Includes Dynamic Applications for monitoring Cisco CUBE devices.

o Cisco: UCS Director

o Cisco: Unity Express (Download from the Customer Portal and Import into SL1)

o Docker (Download from the Customer Portal and Import into SL1)

o ELK: AWS CloudTrail

o ELK: Azure Activity Log

o F5: BIG-IP DNS

o Google Cloud Platform

o Hitachi Data Systems: VSP

o Kubernetes

o Link Layer Neighbor Discovery (Download from the Customer Portal and Import into SL1)

o Microsoft: Office 365

o Microsoft: Windows Server Event Logs

o Palo Alto (Download from the Customer Portal and Import into SL1)

To install a beta PowerPack:

1. Go to the PowerPack Manager page (System > Manage > PowerPacks).

2. Select the [Actions]menu and select Install PowerPack. The PowerPack Installermodal page is displayed.
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Disabling the Knowledge Base

3. Select the lightning-bolt icon ( ) for the PowerPack you want to install. Information about the contents of the
PowerPack and the installation process is displayed.

4. Select the [Install] button.

TIP: By default, installing an updated version of a PowerPack will overwrite all content in a PowerPack that has
already been installed on the target system. You can use the Enable Selective PowerPack Field
Protection setting in the Behavior Settings page (System > Settings > Behavior) to prevent new
PowerPacks from overwriting local changes for some commonly customized fields.

Disabling the Knowledge Base

The Knowledge Base includes known security vulnerabilities. ScienceLogic no longer supports the Knowledge
Base

l If your first installation of SL1 was 8.9.1 or earlier, ScienceLogic strongly recommends that you disable the
Knowledge Base. SL1 provides a setting in the silo.conf file to disable the Knowledge Base.

l For newer installations where the first installation was 8.9.2 or later, the Knowledge Base will be disabled by
default.

WARNING: The Knowledge Base includes known vulnerabilities for cross-site scripting and SQL injection.
ScienceLogic strongly recommends that you disable the Knowledge Base.

To disable the Knowledge Base:

1. Use SSH to connect to the Administration Portal and Database Server or All-In-One (all SL1
appliances that provide a web interface).

2. Use an editor like vi and edit the file /etc/silo.conf. In the LOCAL section, add the line:

kbase_disabled=1

4. Use an editor like vi and edit the file /etc/siteconfig/siloconf.siteconfig. In the LOCAL section, add
the line:

kbase_disabled=1

5. Open a browser session and log in to the SL1

6. From the hamburger menu ( ) in the upper right, select Clear SL1 System Cache.

7. Upon your next login, the Knowledge Base tab will not appear. Attempts to access the tab will result in
an "Access Denied" error message.
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Special Upgrade Process for FIPS-Compliant System

Special Upgrade Process for FIPS-Compliant System

FIPS-compliant systems should use the classic SL1 user interface. The Unified User Interface is not yet FIPS-
compliant.

FIPS-compliant systems (those that are FIPS 140-2 enabled) shouldmanually upgrade to the latest version of
MariaDB.

The platform patch will automatically update MariaDB-client, MariaDB-common, and MariaDB-shared RPMs but
will not update the MariaDB Server.

Upgrade Process for Systems Running 8.1.0 and Earlier

WARNING: ScienceLogic strongly suggest you contact Customer Support or your Customer Success
Manager to plan your migration from CentOS (versions of SL1 prior to 8.1.1) to 8.12.2.

The 8.1.1 release included a complete update of the ScienceLogic appliance operating system from CentOS
5.11 to Oracle Linux. Major operating system components, including the database, web server, and High
Availability/Disaster Recovery packages have been updated or replaced by new industry-standard packages.

When upgrading from a version prior to 8.1.1, each appliance must be migrated to 8.9.0 and the Oracle Linux
7.5 operating system.

Upgrade to 8.9.0

The process of migrating an existing system to 8.9.0 includes multiple additional steps that will vary depending on
your architecture. Please contact your Customer Success Manager to begin a discussion on the migration plan that
is appropriate for your system.

The following is the general process for migrating to 8.9.0. This is a high-level description only. For details,
contact Customer Support or your Customer Success Manager.

l The existing system must be upgraded to at least 7.8.5 before the migration.

l Run the 8.9.0 migration patch.

NOTE: See the separate Migration document for detailed instructions on how to perform the migration steps.
Before you migrate to 8.9.0, please contact your Customer Success Manager.

l Use the 8.9.0 ISO to reinstall all Database Servers or All-In-One Appliances. Data is migrated using a
logical backup while the database on the existing system is stopped. The downtime of this operation can be
mitigated in several ways depending on your current architecture.

l Use the 8.9.0 ISO to reinstall all Administration Portal appliances.
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Upgrade Process for Systems Running 8.4.0 and Later

l After reinstalling all Database Servers and Administration Portals, the system is operational.

l If you want to upgrade to a version later than 8.9.0, you must use the 8.9.0 ISO to reinstall all Data
Collectors and Message Collectors. 8.10.0 and later versions do not support "mixed-mode", where the
Database Servers and Administration Portals are running Oracle Linux and the Data Collectors and Message
Collectors are running CentOS.

l To upgrade to 8.12.2, see the section on Upgrade Process for Systems Running 8.4.0 and Later.

l Perform the steps listed in theOther Manual Updates section.

Features Not Current ly Supported by the 8.x Releases

The following functionality that was available in previous releases is not currently available in the 8.12.2 release,
but will be re-added in a future release:

l Configuring two All-In-One Appliances for Disaster Recovery

l Applying a patch manually with the apply_patch script

Upgrade Process for Systems Running 8.4.0 and Later

As of 8.12.0, SL1 uses an improved System Update tool (System > Tools > Updates). To upgrade to versions of
SL1 of 8.12.0 or later, you must be running SL1 8.4.0 or later. For details on upgrading to 8.4.0 or later, see the
section Upgrade Process for Systems Running 8.1.0 and Earlier or the release notes for 8.4.0.

The 8.12.2 release includes a delta-less update. Any system running 8.6.0 or later can be upgraded to the
8.12.2 release by importing, staging, and deploying a single update file.

To upgrade to the 8.12.2 release from an 8.4.0 or later release:

NOTE: Before upgrading, ensure that:

l Each SL1 Appliance has a valid license

l Each Data Collector is a member of a Collector Group

l Each Data Collector is "available" to the Database Server. To check, see the Collector Status page
(System > Monitor > Collector Status).

NOTE: Staging and deploying SL1 patches is "hitless" and does not require a maintenance window.

1. Familiarize yourself with the Known Issues for this release.

2. For systems running an SL1 version prior to 8.12.0, go to the System Updates page and disable
automatic staging (System > Tools > Updates > Actions > Disable automatic staging).

l If you have previously used manual staging, perform these additional steps:
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Upgrade Process for Systems Running 8.4.0 and Later

o Select all updates in the EM7 Releases pane and select all updates in the ScienceLogic OS pane.

o In the Select Action menu, select Unstage Update (remove staging policy override). Click [Go].

o For software that was previously staged with automatic staging, Unstage Update (remove staging
policy override) does not affect staging.

NOTE: For details on downloading, importing, staging, and installing system updates, see the manual System
Administration.

4. If you are currently running an 8.4 release:

l If you are running 8.4.0 and require access to all ticket notes immediately after upgrading, contact
ScienceLogic Customer Support for details on manually updating the database schema before you
upgrade.

l If you are running 8.4.0 and have added one or more custom firewall rules, such as a non-standard
port for Phone Home Collectors, you must migrate these rules to firewalld before upgrading. Please
contact ScienceLogic Support for more information.

l Please note that 8.10.0 and later versions do not support "mixed-mode", where the Database Servers
and Administration Portals are running Oracle Linux and the Data Collectors and Message Collectors
are running CentOS. If your system uses "mixed-mode", you must use the 8.4.0 ISO to reinstall the
Data Collectors and Message Collectors before upgrading to 8.12.2. ScienceLogic strongly
suggest that you contact Customer Support or your Customer Success Manager to plan your
migration frommixed-mode to 8.12.2.

l From the ScienceLogic portal, download the updates for 8.5.0, 8.6.0, and 8.12.2 to a local
computer. Unzip any zipped files.

l Import the 8.5.0 system update file in the SystemUpdates page (System> Tools > Updates >
Import button). The system update file will load an update in both the EM7 Releases and the
ScienceLogic OS section. You must wait until the update file has imported successfully (i.e. the Import
Status column displays Complete) before importing the next update file.

l Import the 8.6.0 system update file in the SystemUpdates page (System> Tools > Updates >
Import button). The system update file will load an update in both the EM7 Releases and the
ScienceLogic OS section. You must wait until the update file has imported successfully (i.e. the Import
Status column displays Complete) before importing the next update file.

l Review the following release notes to see what has changed between 8.4.x and 8.12.2:

o Applicable 8.4.x release notes (8.4.2 and 8.4.3)

o 8.5.0

o 8.5.1.4

o 8.6.0

o 8.6.1

o 8.6.2.3

o 8.7.0

o 8.7.1.2
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Upgrade Process for Systems Running 8.4.0 and Later

o 8.8.0.1

o 8.8.1.3

o 8.8.2.1

o 8.9.0

o 8.9.1.1

o 8.9.2.4

o 8.10.0

o 8.10.1.3

o 8.10.2.1

o 8.10.3.1

o 8.12.0.2

o 8.12.1.4

o 8.12.2

l Go to step #12 and continue.

5. If you are currently running an 8.5 release:

l Please note that 8.10.0 and later versions do not support "mixed-mode", where the Database Servers
and Administration Portals are running Oracle Linux and the Data Collectors and Message Collectors
are running CentOS. If your system uses "mixed-mode", you must use the 8.5.0 ISO to reinstall the
Data Collectors and Message Collectors before upgrading to 8.12.2. ScienceLogic strongly
suggest that you contact Customer Support or your Customer Success Manager to plan your
migration frommixed-mode to 8.12.2.

l From the ScienceLogic portal, download the updates for 8.6.0 and 8.12.2 to a local computer.
Unzip any zipped files.

l Import the 8.6.0 system update file in the SystemUpdates page (System> Tools > Updates >
Import button). The system update file will load an update in both the EM7 Releases and the
ScienceLogic OS section. You must wait until the update file has imported successfully (i.e. the Import
Status column displays Complete) before importing the next update file.

l Review the following release notes to see what has changed between 8.5.x and 8.12.2:

o Applicable 8.5.x release notes (8.5.1.4)

o 8.6.0

o 8.6.1

o 8.6.2.3

o 8.7.0

o 8.7.1.2

o 8.8.0.1

o 8.8.1.3

o 8.8.2.1

14



Upgrade Process for Systems Running 8.4.0 and Later

o 8.9.0

o 8.9.1.1

o 8.9.2.4

o 8.10.0

o 8.10.1.3

o 8.10.2.1

o 8.10.3.1

o 8.12.0.2

o 8.12.1.4

o 8.12.2

l Go to step #12 and continue.

6. If you are currently running an 8.6 release:

l Please note that 8.10.0 and later versions do not support "mixed-mode", where the Database Servers
and Administration Portals are running Oracle Linux and the Data Collectors and Message Collectors
are running CentOS. If your system uses "mixed-mode", you must use the 8.6.0 ISO to reinstall the
Data Collectors and Message Collectors before upgrading to 8.12.2. ScienceLogic strongly
suggest that you contact Customer Support or your Customer Success Manager to plan your
migration frommixed-mode to 8.12.2.

l From the ScienceLogic portal, download the update for 8.12.2 to a local computer. Unzip any
zipped files.

l Review the following release notes to see what has changed between 8.7.x and 8.12.2:

o Applicable 8.6.x release notes (8.6.1 and 8.6.2.3)

o 8.7.0

o 8.7.1.2

o 8.8.0.1

o 8.8.1.3

o 8.8.2.1

o 8.9.0

o 8.9.1.1

o 8.9.2.4

o 8.10.0

o 8.10.1.3

o 8.10.2.1

o 8.10.3.1

o 8.12.0.2

o 8.12.1.4

o 8.12.2
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l Go to step #12 and continue.

7. If you are currently running an 8.7 release:

l Please note that 8.10.0 and later versions do not support "mixed-mode", where the Database Servers
and Administration Portals are running Oracle Linux and the Data Collectors and Message Collectors
are running CentOS. If your system uses "mixed-mode", you must use the 8.7.0 ISO to reinstall the
Data Collectors and Message Collectors before upgrading to 8.12.2. ScienceLogic strongly
suggest that you contact Customer Support or your Customer Success Manager to plan your
migration frommixed-mode to 8.12.2.

l From the ScienceLogic portal, download the update for 8.12.2 to a local computer. Unzip any
zipped files.

l Review the following release notes to see what has changed between 8.8.x and 8.12.2:

o Applicable 8.7.x release notes (8.7.1.2)

o 8.8.0.1

o 8.8.1.3

o 8.8.2.1

o 8.9.0

o 8.9.1.1

o 8.9.2.4

o 8.10.0

o 8.10.1.3

o 8.10.2.1

o 8.10.3.1

o 8.12.0.2

o 8.12.1.4

o 8.12.2

l Go to step #12 and continue.

8. If you are currently running an 8.8 release:

l Please note that 8.10.0 and later versions do not support "mixed-mode", where the Database Servers
and Administration Portals are running Oracle Linux and the Data Collectors and Message Collectors
are running CentOS. If your system uses "mixed-mode", you must use the 8.8.0 ISO to reinstall the
Data Collectors and Message Collectors before upgrading to 8.12.2. ScienceLogic strongly
suggest that you contact Customer Support or your Customer Success Manager to plan your
migration frommixed-mode to 8.12.2.

l From the ScienceLogic portal, download the update for 8.12.2 to a local computer. Unzip any
zipped files.

l Review the following release notes to see what has changed between 8.9.x and 8.12.2:

o Applicable 8.8.x release notes (8.8.0.1, 8.8.1.3, 8.8.2.1)

o 8.9.0
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o 8.9.1.1

o 8.9.2.4

o 8.10.0

o 8.10.1.3

o 8.10.2.1

o 8.10.3.1

o 8.12.0.2

o 8.12.1.4

o 8.12.2

l Go to step #12 and continue.

9. If you are currently running an 8.9 release:

l Please note that 8.10.0 and later versions do not support "mixed-mode", where the Database Servers
and Administration Portals are running Oracle Linux and the Data Collectors and Message Collectors
are running CentOS. If your system uses "mixed-mode", you must use the 89.0 ISO to reinstall the
Data Collectors and Message Collectors before upgrading to 8.12.2.ScienceLogic strongly suggest
that you contact Customer Support or your Customer Success Manager to plan your
migration frommixed-mode to 8.12.2.

l From the ScienceLogic portal, download the update for 8.12.2 to a local computer. Unzip any
zipped files.

l Review the following release notes to see what has changed between 8.10.x and 8.12.2:

o Applicable 8.9.x release notes (8.9.1.1, 8.9.2.4)

o 8.10.0

o 8.10.1.3

o 8.10.2.1

o 8.10.3.1

o 8.12.0.2

o 8.12.1.4

o 8.12.2

l Go to step #12 and continue.

10. If you are currently running an 8.10 release:

l From the ScienceLogic portal, download the latest update for 8.12.2 to a local computer. Unzip
any zipped files.

l Review the following release notes to see what has changed between 8.12.0 and 8.12.2:

o Applicable 8.10.x release notes (8.10.1.3, .8.10 2.1, 8.10.3.1)

o 8.12.0.2
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o 8.12.1.4

o 8.12.2

l Go to step #12 and continue.

11. If you are currently running an 8.12.x release:

l From the ScienceLogic portal, download the update for 8.12.2 to a local computer. Unzip any
zipped files.

l Review the following release notes to see what has changed between 8.12.x and 8.12.2:

o Applicable 8.12.x release notes (8.12.0.2, 8.12.1.4)

o 8.12.2

l Go to step #12 and continue.

12. Import the 8.12.2 system update file in the System Updates page (System > Tools > Updates > [Import]
button).

13. Select the staging icon ( ) for 8.12.2.

14. When staging has completed, select the lightning-bolt icon ( ) to deploy 8.12.2.

15. Clear your browser's cache.

16. Clear the SL1 cache.

l Go to the CacheManagement page (System > Tools > Cache).

l From the hamburger menu ( ), select Clear EM7 System Cache.

CAUTION: An update included in 8.12.1 requires that you clear the EM7 System Cache. Until you clear the
EM7 System Cache, you might experience errors with credentials that can affect discovery, calls
to the ScienceLogic API, and calls to GQL.

17. Go to the PowerPack Manager page (System > Manage > PowerPacks) and install all updated
PowerPacks. Updated PowerPacks are loaded on your ScienceLogic system by the patch process. To install
an updated PowerPack, find the PowerPack in the PowerPack Manager page and select the installation

icon ( ) in the Update column for the PowerPack or use the Update PowerPacks option in the Select
Action drop-down list.

TIP: By default, installing an updated version of a PowerPack will overwrite all content in that PowerPack that
has already been installed on the target system. You can use the Enable Selective PowerPack Field
Protection setting in the Behavior Settings page (System > Settings > Behavior) to prevent new
PowerPacks from overwriting local changes for some commonly customized fields.
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18. If you are monitoring devices using the ScienceLogic Agent, follow the steps listed in the Agent Monitoring
manual to upgrade to the latest version of the Agent.

19. If you upgraded from an 8.4.x release, perform the steps listed in theOther Manual Updates section.

CAUTION:Upgrading MariaDB and the rebooting all SL1 appliances should be performed during a
maintenance window. If you would like assistance in planning an upgrade path that minimizes
downtime, please contact your Customer Success Manager.

20. If you have not previously upgraded to 8.12.0, you must upgrade MariaDB to the latest version. To do so,
perform the steps in the Upgrading MariaDB section.

21. 8.12.2 includes important security updates that require you to reboot all appliances after installing
8.12.2. If you would like assistance in planning an upgrade path that meets your security needs while
minimizing downtime, please contact your Customer Success Manager.

Manual Updates for 8.4.x Systems Updated to 8.12.2

If you upgraded from an 8.4.x system to 8.12.2, after 8.12.2 is installed, you must manually apply the following
changes to every Message Collector and All-In-One Appliance in your system:

1. Either go to the console or use SSH to access the server.

2. Log in as user em7admin with the appropriate password.

3. Enter the following at the command line:

sudo vi /etc/siteconfig/siloconf.siteconfig

4. Locate the following line:

eventmanager = syslog,trap,internal

NOTE: On an All-In-One Appliance, this line will include additional entries in the comma-delimited
list.

5. Add ",agent" to the end of the line. The line should now look like this:

eventmanager = syslog,trap,internal,agent

6. Save the file and exit vi (:wq).

7. At the command line, enter the following command to rebuild the configuration file:

sudo /opt/em7/share/scripts/generate-silo-conf.py > /etc/silo.conf
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Upgrading MariaDB

Version 8.12.0 requires updates to MariaDB that address security and performance issues. If you have not
previously installed an 8.12.x version, the 8.12.x platform patch will automatically update MariaDB-client,
MariaDB-common, and MariaDB-shared RPMs but will not update the MariaDB Server RPM. You must manually
update the MariaDB Server RPM. You can download the latest approved MariaDB updates at
https://portal.sciencelogic.com/portal/miscellaneous.

NOTE: To address security issues, download the latest MariaDB updates. Earlier MariaDB updates remain on
the portal to support users who have not yet migrated to the latest release.

The following sections describe how to perform this upgrade for different appliance types and architectures.

Two Database Servers Configured for High Availability

To upgrade a High Availability cluster, perform the following steps:

WARNING: The system will be unavailable when performing these steps.

1. Copy the MariaDB RPMs to the file system of both appliances.

2. Log in to the command-line of both Database Server appliances as em7admin.

3. Execute the following command on the secondary Database Server:

sudo systemctl stop pacemaker.service

4. Execute the following command on the primary Database Server to determine the current installed version of
the RPMs:

sudo rpm -qa ^MariaDB-*

5. Execute the following command on the primary Database Server:

sudo systemctl stop mysql

6. On the primary Database Server, navigate to the directory that you copied the RPMs.

7. For each RPM that the output from step 5 showed at an earlier version, execute the following command on
the primary Database Server:

sudo rpm -Uvh <file name of RPM>

8. Execute the following command on the primary Database Server to validate that the RPMs installed correctly:

sudo rpm -qa ^MariaDB-*

9. Execute the following command on the primary Database Server:

sudo systemctl start mysql
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10. Execute the following command on the primary Database Server, replacing the password for the root
database user when prompted:

sudo mysql_upgrade -u root -p

11. On the secondary Database Server, execute the following command to determine the current installed
version of the RPMs:

sudo rpm -qa ^MariaDB-*

12. On the secondary Database Server, navigate to the directory where you copied the RPMs.

13. For each RPM that the output from step 11 showed at an earlier version of MariaDB, execute the following
command on the secondary Database Server:

sudo rpm -Uvh <file name of RPM>

14. Execute the following command on the secondary Database Server to validate that the RPMs installed
correctly:

sudo rpm -qa ^MariaDB-*

15. Execute the following command on the secondary Database Server:

sudo systemctl start pacemaker.service

Two Database Servers Configured for Disaster Recovery

To upgrade two Database Servers configured for disaster recovery, perform the following steps:

WARNING: The system will be unavailable when performing these steps.

1. Copy the latest RPMs to the file system of both appliances.

2. Log in to the command-line of both Database Server appliances as em7admin.

3. Execute the following command on the primary Database Server to determine the current installed version of
the RPMs:

sudo rpm -qa ^MariaDB-*

4. Execute the following command on the primary Database Server:

sudo systemctl stop mysql

5. On the primary Database Server, navigate to the directory that you copied the RPMs.

6. For each RPM that the output from step 4 showed at an earlier version, execute the following command on
the primary Database Server:

sudo rpm -Uvh <file name of RPM>

7. Execute the following command on the primary Database Server to validate that the RPMs installed correctly:

sudo rpm -qa ^MariaDB-*
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8. Execute the following command on the primary Database Server:

sudo resource start mysql

9. Execute the following command on the primary Database Server, replacing the password for the root
database user where indicated:

sudo mysql_upgrade -u root -p

10. On the secondary Database Server, execute the following command to determine the current installed
version of the RPMs:

sudo rpm -qa ^MariaDB-*

11. On the secondary Database Server, navigate to the directory where you copied the RPMs.

12. For each RPM that the output from step 10 showed at an earlier version, execute the following command on
the secondary Database Server:

sudo rpm -Uvh <file name of RPM>

13. Execute the following command on the secondary Database Server to validate that the RPMs installed
correctly:

sudo rpm -qa ^MariaDB-*

Three Database Servers Configured for HA and DR

To upgrade a High Availability cluster, perform the following steps:

WARNING: The system will be unavailable when performing these steps.

1. Copy the latest RPMs to the file system of all three appliances.

2. Log in to the command-line of all three Database Server appliances as em7admin.

3. Execute the following command on the secondary Database Server in the HA cluster:

sudo systemctl stop pacemaker.service

4. Execute the following command on the primary Database Server in the HA cluster to determine the current
installed version of the RPMs:

sudo rpm -qa ^MariaDB-*

5. Execute the following command on the primary Database Server in the HA cluster:

sudo systemctl stop mysql

6. On the primary Database Server in the HA cluster, navigate to the directory that you copied the RPMs.

7. For each RPM that the output from step 5 showed at an earlier version, execute the following command on
the primary Database Server in the HA cluster:

sudo rpm -Uvh <file name of RPM>

8. Execute the following command on the primary Database Server in the HA cluster to validate that the RPMs
installed correctly:
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sudo rpm -qa ^MariaDB-*

9. Execute the following command on the primary Database Server in the HA cluster:

sudo systemctl start mysql

10. Execute the following command on the primary Database Server in the HA cluster, replacing the password for
the root database user where indicated:

sudo mysql_upgrade -u root -p

11. On the secondary Database Server, execute the following command to determine the current installed
version of the RPMs:

sudo rpm -qa ^MariaDB-*

12. On the secondary Database Server, navigate to the directory where you copied the RPMs.

13. For each RPM that the output from step 11 showed at an earlier version, execute the following command on
the secondary Database Server:

sudo rpm -Uvh <file name of RPM>

14. Execute the following command on the secondary Database Server in the HA cluster to validate that the RPMs
installed correctly:

sudo rpm -qa ^MariaDB-*

15. Execute the following command on the secondary Database Server in the HA cluster:

sudo systemctl start pacemaker.service

16. On the Database Server for disaster recovery, execute the following command to determine the current
installed version of the RPMs:

sudo rpm -qa ^MariaDB-*

17. On the Database Server for disaster recovery, navigate to the directory that you copied the RPMs.

18. For each RPM that the output from step 16 showed at an earlier version, execute the following command on
the Database Server for disaster recovery:

sudo rpm -Uvh <file name of RPM>

19. Execute the following command on the secondary Database Server in the HA cluster to validate that the RPMs
installed correctly:

sudo rpm -qa ^MariaDB-*

20. Execute the following command on the Database Server for disaster recovery to validate that the RPMs
installed correctly:

sudo rpm -qa ^MariaDB-*

Single Database Server/All-In-One Appliance/Data
Collector/Message Collector

To upgrade MariaDB on a single Database Server, All-In-One Appliance, Data Collector, or Message Collector,
perform the following steps:
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WARNING: The Database Server, All-In-One Appliance, Data Collector, or Message Collector will be
inoperable when performing these steps.

1. Copy the latest RPMs to the file system of the appliance:

2. Log in to the command-line of the appliance as em7admin.

3. Execute the following commands:

sudo systemctl stop em7
sudo systemctl stop mariadb.service

4. Execute the following command to determine the current installed version of the RPMs:

sudo rpm -qa ^MariaDB-*

5. Navigate to the directory that you copied the RPMs.

6. For each RPM that the output from step 4 showed at an earlier version, execute the following command:

sudo rpm -Uvh <file name of RPM>

7. Execute the following command to validate that the RPMs installed correctly:

sudo rpm -qa ^MariaDB-*

8. Execute the following commands:

sudo systemctl daemon-reload
sudo systemctl start mariadb.service

9. Execute the following command, replacing the password for the root database user where indicated:

sudo mysql_upgrade -u root -p

10. Execute the following command to re-start SL1:

sudo systemctl start em7

Rebooting Appliances

Use the applicable steps listed in this section to reboot your appliances.

Administrat ion Portal

If your SL1 system includes multiple Administration Portals, you can remotely reboot Administration Portals from
another Administration Portal. To do so:

1. Go to the Appliance Manager page (System > Settings > Appliances).

2. Select the checkboxes for the appliances you want to reboot.

3. In the [Select Action]menu, select Reboot and click the Go button.

4. Click the OK button when the "Are you sure you want to reboot the selected appliances?" message is
displayed.
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5. During the reboot, the user interface for the affected Administration Portals is unavailable.

6. When the reboot has completed, the Audit Logs page (System > Monitor > Audit Logs) will include an entry
for each appliance that was rebooted.

If your SL1 system include only a single Administration Portal, perform the following steps to reboot that
Administration Portal:

1. Either go to the console of the Database Server or use SSH to access the server.

2. Log in as em7admin with the appropriate password.

3. At the shell prompt, execute the following:

python -m silo_common.admin_toolbox <appliance_ID> "/usr/bin/sudo /usr/sbin/shutdown
-r +1"

where:

l appliance_ID is the appliance ID for the Data Collector, Message Collector, or Administration Portal.

Data Collectors and Message Collectors

You can reboot Data Collector and Message Collectors either from the user interface or from the command line.

From the SL1 user interface, perform the following steps to reboot a Data Collector or Message Collector:

1. Go to the Appliance Manager page (System > Settings > Appliances).

2. Select the checkboxes for the appliances you want to reboot.

3. In the [Select Action]menu, select Reboot and click the Go button.

4. Click the OK button when the "Are you sure you want to reboot the selected appliances?" message is
displayed.

5. During the reboot, go to the System Logs page (System > Monitor > System Logs). You should see this
message:

Major: Could not connect to module (5) database USING SSL=TRUE: Error attempting
to connect to database with SSL enabled True: (2003, 'Can't connect to MySQL
server on '10.2.12.77' (113 "No route to host")')

6. When the reboot has completed, the Audit Logs page (System > Monitor > Audit Logs) will include an entry
for each appliance that was rebooted.

From the console of the Database Server or SSH to the Database Server, perform the following steps to reboot a
Data Collector or Message Collector:

1. Either go to the console of a Database Server or SSH to access the server.

2. Log in as em7admin with the appropriate password.

3. At the shell prompt, execute the following:

python -m silo_common.admin_toolbox <appliance_ID> "/usr/bin/sudo /usr/sbin/shutdown
-r +1"

where:
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l appliance_ID is the appliance ID for the Data Collector, Message Collector, or Administration Portal.

Standalone All-In-One Appliances and Database Servers

Perform the following steps to reboot a standalone All-In-One Appliance or Database Server:

1. Either go to the console or use SSH to access the server.

2. Log in as em7admin with the appropriate password.

3. Execute the following commands on the appliance to pause the system and shutdown MariaDB. Enter the
password for the em7admin user when prompted:

sudo touch /tmp/.proc_mgr_pause
sudo systemctl stop mariadb

4. Execute the following command on the appliance to reboot the appliance:

sudo reboot

5. After the appliance has rebooted, log in to the appliance as the em7admin user using the console or SSH.

6. Execute the following command on the appliance to un-pause the system:

sudo rm /tmp/.proc_mgr_pause

7. Enter the password for the em7admin user and confirm the command when prompted.

Two Database Servers Configured for Disaster Recovery

Perform the following steps to reboot two Database Servers configured for Disaster Recovery:

1. Either go to the console of the primary Database Server or use SSH to access the server.

2. Log in as em7admin with the appropriate password.

3. First, you should check the status of the appliances. To do this, enter the following at the shell prompt:

cat /proc/drbd

4. Your output will look like this:

1: cs:Connected ro:Primary/Secondary ds:UpToDate/UpToDate C r----
ns:17567744 al:0 bm:1072 lo:0 pe:0 ua:0 ap:0 ep:1 wo:b oos:12521012

NOTE: If your output includes "ro:Primary/Secondary", but does not include "UpToDate/UpToDate",
data is being synchronized between the two appliances. You must wait until data
synchronization has finished before rebooting.

5. Execute the following commands on the primary appliance to pause the system and shutdown MariaDB.
Enter the password for the em7admin user when prompted:

sudo touch /tmp/.proc_mgr_pause
sudo systemctl stop pacemaker

6. Execute the following command on the primary appliance to reboot the appliance:

sudo reboot
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7. After the primary appliance has rebooted, log in to the console of the primary appliance again.

8. Execute the following commands on the primary appliance:

sudo rm /tmp/.proc_mgr_pause

9. Enter the password for the em7admin user and confirm the command when prompted.

10. Log in to the secondaryDatabase Server as the em7admin user using the console or SSH.

11. Execute the following command on the secondary appliance to reboot the appliance:

sudo reboot

12. Enter the password for the em7admin user when prompted.

Two Database Servers in a High Availability Cluster

Perform the following steps to reboot two Database Servers in a high availability cluster:

1. Either go to the console of the secondary Database Server or use SSH to access the server.

2. Log in as em7admin with the appropriate password.

3. First, you should check the status of the appliances. To do this, enter the following at the shell prompt:

cat /proc/drbd

4. Your output will look like this:

1: cs:Connected ro:Secondary/Primary ds:UpToDate/UpToDate C r----
ns:17567744 al:0 bm:1072 lo:0 pe:0 ua:0 ap:0 ep:1 wo:b oos:12521012

NOTE: If your output includes "ro:Secondary/Primary", but does not include "UpToDate/UpToDate", data is
being synchronized between the two appliances. You must wait until data synchronization has finished
before rebooting.

5. Execute the following command on the secondary appliance to stop the cluster service:

sudo systemctl stop pacemaker

6. Enter the password for the em7admin user when prompted.

7. Log in to the primaryDatabase Server as the em7admin user using the console or SSH.

8. Execute the following commands on the primary appliance to pause the system and stop the cluster service.
Enter the password for the em7admin user when prompted:

sudo touch /tmp/.proc_mgr_pause
sudo systemctl stop pacemaker

9. Execute the following command on the primary appliance to reboot the appliance:

sudo reboot

10. After the primary appliance has rebooted, log in to the console of the primary appliance again.
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11. Execute the following command on the primary appliance:

sudo rm /tmp/.proc_mgr_pause

12. Enter the password for the em7admin user and confirm the command when prompted.

13. Ensure that the user interface is now available on the primary appliance.

14. Log in to the secondaryDatabase Server as the em7admin user using the console or SSH.

15. Execute the following command on the secondary appliance to reboot the appliance:

sudo reboot

16. Enter the password for the em7admin user when prompted.

Three Database Servers Configured for High Availability and Disaster
Recovery

Perform the following steps to reboot three Database Servers configured for high availability and disaster recovery:

1. Either go to the console of the secondary Database Server in the HA cluster or use SSH to access the
server.

2. Log in as em7admin with the appropriate password.

3. First, you should check the status of the appliances. To do this, enter the following at the shell prompt:

cat /proc/drbd

4. Your output will look like this:

10: cs:Connected ro:Secondary/Primary ds:UpToDate/UpToDate C r----
ns:17567744 al:0 bm:1072 lo:0 pe:0 ua:0 ap:0 ep:1 wo:b oos:12521012

NOTE: If your output includes "ro:Secondary/Primary", but does not include "UpToDate/UpToDate", data is
being synchronized between the two appliances. You must wait until data synchronization has finished
before rebooting.

5. Execute the following command on the secondary Database Server in the HA cluster to stop the cluster
service:

sudo systemctl stop pacemaker

6. Enter the password for the em7admin user when prompted.

7. Log in to primaryDatabase Server as the em7admin user using the console or SSH.

8. Execute the following commands on the primary appliance to pause the system and stop the cluster service.
Enter the password for the em7admin user when prompted:

sudo touch /tmp/.proc_mgr_pause
sudo systemctl stop pacemaker
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9. Execute the following command on the primary appliance to reboot the appliance:

sudo reboot

10. After the primary appliance has rebooted, log in to the console of the primary appliance again.

11. Execute the following command on the primary appliance:

sudo rm /tmp/.proc_mgr_pause

12. Enter the password for the em7admin user and confirm the command when prompted.

13. Log in to the secondary Database Server in the HA cluster as the em7admin user using the console or
SSH.

14. Execute the following command on the secondary Database Server in the HA cluster to reboot the
appliance:

sudo reboot

15. Enter the password for the em7admin user when prompted.

16. Log in to the Database Server for Disaster Recovery as the em7admin user using the console or SSH.

17. Execute the following command on the Database Server for Disaster Recovery to reboot the appliance:

sudo reboot

18. Enter the password for the em7admin user when prompted.

Deprecated Features

As of the 8.2.0 release, the following PowerPacks are no longer included in the default ISO. These PowerPacks
will not be automatically removed from an existing system during an upgrade and will remain available for
download on the ScienceLogic Portal:

l ADIC Base Pack

l Ascend Communications Base Pack

l Cabletron System Base Pack

l CloudKick Management

l GoGrid Base Pack

l Informant Cluster

l Informant Exchange

l Informant MS SQL

l Informant Windows OS

l NTI Base Pack

l Rackspace Base Pack

l Redback Base Pack

l RIM Blackberry Base Pack
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Deprecated Features

l Sensatronics Base Pack

l SystemEdge Base Pack

l System Uptime

l Tipping Point Base Pack

l Xirrus Base Pack

The new user interface architecture requires API access for all users; API access is automatically granted to users.
The following API-specific access hooks have been deprecated and removed from the product:

l API: Resource Indexes

l API: Server Access

l API: Virtual Device

The following functionality that was available in previous releases is no longer available in the 8.12.1 release:

l The process for generating rollup/normalized data has been updated to improve performance and
scalability. This update deprecates the generation of frequent rollup data. The following user interface pages
are affected:

o The widgets Leaderboard/Top-N, Leaderboard/Top-N (secondary), and Multi-Series Performance no
longer support Frequent normalization. If these widgets are used by older dashboards and are already
configured to use Frequent normalization, the platform will automatically update these widgets to use
hourly normalization.

o In the Collection Labels page (System > Manage > Collection Labels), the Frequent Data column is
deprecated.

l The Cisco Nexus PowerPack has been removed from the default build and is no longer supported. However,
the PowerPack is not deleted during the upgrade process. The device classes for Cisco Nexus devices are
now included in the Cisco: Base Pack PowerPack.

l The ScienceLogic Agent no longer supports 32-bit versions of Linux or Windows.

l The third-party Azure python library has been removed from the ISO build.

l The FTP, SFTP, NFS, and SMB backup options that stage locally are no longer supported.

l The EMC Base Pack PowerPack has been removed from the default build and is no longer supported.
However, the PowerPack is not deleted during the upgrade process. If you are still using the EMC Base Pack
PowerPack, ScienceLogic recommends using the EMC: VNX PowerPack instead.

l The SAN wizard is no longer supported. ScienceLogic will no longer provide direct support for configuring a
SAN for data storage.

l Integration Server appliances are no longer supported.

l Root access is not enabled on any appliance.

l The VMware: vCloud PowerPack has been removed from the ISO build and is no longer supported.

l The "ifconfig" command is no longer supported by the new appliance operating system. The "ip addr"
command must be used instead.

l NOC Screens (System > Manage > Screens) are no longer included in the platform. To re-enable this
feature, contact ScienceLogic Customer Support.
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Known Issues

l The Knowledge Base is no longer supported by ScienceLogic and will be disabled by default for new users.

l High-Availability and Disaster Recovery no longer support the command "drbd-overview". To check the status
of drbd, use "cat /proc/drbd".

l System Update no longer supports the shell command "deploy_patch".

Known Issues

For a list of Known Issues and workarounds, see the ScienceLogic Customer Portal at
https://support.sciencelogic.com/s/topic/0TO0z000000E6w7GAC/known-issues.

Overview

This document describes:

l The New Features in the 8.12.1 release

l The Issues Addressed in the 8.12.1 release

l The PowerPacks included in the 8.12.1 release

l New and Updated Packages in the 8.12.1 release

l The Beta Features available with the 8.12.1 release

l Disabling the Knowledge Base

l Special Upgrade Process for FIPS-Compliant Systems

l Special Considerations for Systems Running 8.4.1 or Earlier

l Upgrade Process for 7.x Systems

l Upgrade Process for Systems Running 8.4.0 and Later

l Upgrading MariaDB

l Manual Updates for 8.4.x Systems Updated to 8.12.1

l Rebooting Appliances

l The features deprecated in the 8.12.1 release

WARNING:Do not import 8.12.0 or 8.12.1 if you do not plan to immediately consume the 8.12.x
line of releases. After you import an 8.12.0 release, all appliances in your SL1 system will now
use the new system update. After you import an 8.12.0 release, you will not be able to stage
and deploy any versions of SL1 previous to 8.12.0 or apply patches to versions of SL1 previous to
8.12.0.
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Overview

WARNING: To install 8.12.1 and its new SystemUpdates tool, you have must have already imported,
staged, and deployed 8.4.0

WARNING: 8.12.1 includes important security updates that require you to reboot all appliances
after installing 8.12.1. If you would like assistance in planning an upgrade path that meets your
security needs while minimizing downtime, please contact your Customer Success Manager.

WARNING: 8.10.0 and later releases do not support Data Collectors and Message Collectors
running the CentOS operating system. If your system includes Data Collectors and
Message Collectors running the CentOS operating system, contact your Customer
Success Manager for details on upgrading Data Collectors and Message Collectors to
Oracle Linux before installing 8.12.1.

WARNING: To apply updates to an existing Data Collector, that Data Collector must be a member of a
Collector Group. In some SL1 systems, users might have to create a Collector Group for a single
Data Collector.

WARNING: ScienceLogic strongly suggest you contact Customer Support or your Customer Success
Manager to plan your migration from CentOS (versions of SL1 prior to 8.1.1) to 8.12.1.

WARNING: 7.x systems must be upgraded to 7.8.5 before migration to the 8.9.0 release (using a special
migration patch). After migration to 8.9.0, users can upgrade to releases later than 8.9.0.
Upgrading to 8.10.0 and later requires re-building all Data Collectors and Message Collectors.
Please contact your Customer Success Manager to begin a discussion on the migration plan that
is appropriate for your system.

WARNING: The Knowledge Base includes known vulnerabilities for cross-site scripting and SQL injection. If
you are updating from a previous installation, ScienceLogic strongly recommends that you
disable the Knowledge Base.

WARNING: If your system is not currently running a recent release, the upgrade process includes importing
multiple upgrade files. You must wait until an update file has imported successfully (i.e. the
Import Status column displays Complete in both the EM7 Release pane and the ScienceLogic
OS pane) before importing the next update file.
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New Features in 8.12.1

CAUTION: ScienceLogic recommends that Systems running an AP2 version earlier than 5.55.1.3 upgrade
their version of AP2 before upgrading to 8.12.1. For details, see the manual Using the New
User Interface, section onManaging New Features on the Content Management Page.

CAUTION: Before installing a release, ScienceLogic recommends that you verify that recent backups are
available for your system.

CAUTION:During the normal system update process, multiple processes are stopped and restarted. This
might result in missed polls, gaps in data, and/or unexpected errors. ScienceLogic recommends
that you always install ScienceLogic releases during a maintenance window.

CAUTION: The ScienceLogic system update process starts a background process that can perform any
required post-upgrade tasks. The post-patch update process is automatically stopped after 24
hours. However, depending on the size of your database as well as the version from which you
are upgrading, the post-upgrade tasks can take several days to perform. If the post-patch update
process is stopped after 24 hours, the process will automatically re-start and continue processing
from the point at which it was stopped. If you see an event that indicates the post-patch update
process was stopped, you do not need to contact ScienceLogic support for assistance until you see
the same event for three consecutive days.

TIP: Before you install a ScienceLogic release, ScienceLogic recommends reviewing the hardware
specifications of all the appliances in your system to ensure they meet the requirements for the current
usage of your system. For more information, see https://support.sciencelogic.com/s/system-requirements

TIP: ScienceLogic regularly uploads new and updated PowerPacks to the Customer Portal before packaging
those PowerPacks in a system update file. For more information, see
https://portal.sciencelogic.com/portal/powerpacks.

New Features in 8.12.1

8.12.1 Unified UI includes the following new features:

NOTE: The unified UI includes pages from the SL1 Classic UI, displayed in either the SL1 Classic UI and
ported to the SL1 Next UI.

Content Libraries
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New Features in 8.12.1

l Updated pip, setuptools, and wheel to latest versions, to support third-party content libraries.

Dynamic Applications

l Improved the performance of the Dynamic Application process that checks each auto-disabled collection
object on a device and re-enables the collection object when appropriate.

Form Fields

l Improved custom form fields in the Application forms page (System > Customize > Form Fields). In the
Form Creator modal page, the field types Varchar32, Varchar48 and Varchar64 have been replaced with a
field of type TextArea. The new fields can include up to 64K characters

Logging

l Added new page PHP Developer Logs (System > Tools > PHP Developer Logs) to SL1. These logs aid
ScienceLogic Customer Support when troubleshooting problems with the user interface.

PhoneHome

l In a High Availability system, only the Database Server that is also the PhoneHome control node may
generate a PhoneHome token for the Data Collectors. (Support ID: 153173) ( Support ID: 161661)(Support
ID: 172370)(Case 00006471)

PowerShell

l If a PowerShell Dynamic Application terminates before closing its open connections, SL1 will automatically
close the open PowerShell connections.

l PowerShell Dynamic Applications that are cache producers or cache consumer now successfully collect data
from merged devices.

System Update

l Improved System Updates (System > Tools > Updates). After successful deployment or successfully staging a
later version of an update, System Update now removes packages that were copied to each SL1 appliance
during staging.

8.12.1 Next UI includes the following new features:

NOTE: Features in this section are not available in the SL1 Classic UI.

User Interface Version

l 8.12.1 includes the following version of the user interface:

o AP2_5.125.44.

General
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New Features in 8.12.1

l When searching, you can click the menu icon to the right of the Search field to open a menu containing
related search criteria. In that menu, you can select a search criteria and type additional search information.

l If you select a date-related search criteria from the list of criteria in Basic Search, you can use a drop-down
calendar to select a specific date.

l Basic Search and Advanced Search were updated to include better search queries and usability.

l For an Administrator user, the End User License Agreement (EULA) appears the first time that user logs into
SL1. The user must agree to the terms before using SL1.

Applications

l From the Application Investigator page, you can view the details of that application, view and add
application components or devices to that application, and edit the status policy aligned with that application.

l The [Rules] button on the [Devices] tab for an application component lets you define the processes and
arguments to monitor for that application component.

l The [Define these with a Query ]button on the [Devices] tab for an application component lets you update
the set of devices in that application component.

l You can edit an application component by clicking the [Actions] button for that component on the
Applications page.

l You can create static or dynamic searches for the devices you want to add to an application component.

l You can view both statically defined and dynamically defined application components on the Application
Investigator page.

l When creating an application or an application component, you can search for business, IT, and device
services.

l Improved error messaging was added if you try to add non-devices to an application component.

Dashboards

l You can now create Application and Application Component widgets.

l The Auto-Select option was moved from the All Filters window to the widget creation process, where you
can select the number of items that are automatically selected in the context-driving widgets.

l In a Service widget, you can link directly to another dashboard or item related to that service.

l The dashboard creator can choose a specific dashboard from a list that is linked to a leaderboard, so the user
can specify a dashboard without copy and pasting a URL and using a parameter.

l If a dashboard creator doesn't enter a new name for a map widget, the name of the map will be used.

l The icon in a service tile widget is still visible even when the service is unavailable.

l Leaderboard bar chart widgets can now drive context.

l Event widgets can now drive context.

l Selecting items in a map widget will drive context in other widgets.

l Custom Attributes can now be selected underMetrics and Properties when creating a device table or event
table widget.

Devices
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New Features in 8.12.1

l You can change the aligned Device Class from the Info drop-down on the Device Investigator page for a
device.

l You can generate a report for a device from the Device Investigator page.

l The [Settings] tab on the Device Investigator page was updated with additional options.

l On the [Events] tab for the Device Investigator page, you can toggle between cleared and active events for
a device.

l On the [Events] tab for the Device Investigator page, you can use the Search field to filter the list of events
for that device.

l On the [Interfaces] tab for the Device Investigator page, you can click the interface name from the list of
interfaces to open the Interface Properties page for that interface.

l If an SL1 system is configured to use Maps, the [Map] tab on the Device Investigator page displays by
default.

l The Tools drop-down on the Device Investigator page does not display if the user does not have
permissions for the device tools. The Tools drop-down now includes an Availability tool.

l You can drag and drop the various tabs on the Device Investigator page to rearrange the order of the tabs.

l Hovering over a column in the Devices page displays a ToolTip with the complete value if the value was cut
off by the column width.

l You can now assign icons to devices.

l Users need proper permissions to edit Device Categories and Device Classes.

Events

l You can view the automations that were run on a certain event by selecting View Automation Actions from the
Actions menu on the Events page.

l From the View drop-down on the Events page, you can toggle the ability to group events generated from a
Business Service, events from its IT Services and their Device Services, and events from the underlying
devices.

l From the View drop-down on the Events page, you can specify a time frame for SL1 to auto-refresh and
display new events. You can also click the Refresh icon at the top right of the Events page table to manually
refresh the list of events.

l The Actions menu from the Events page is also available at the top right of the Event Investigator page for
an individual event.

l The Card view for the Events page has been deprecated.

l Custom Attributes can now be selected to display as columns in the Events page.

Maps

l The Design pane for a map was updated and streamlined, and the configurable design options now include
Tiered Hierarchy, Hierarchy, and Force Directed. For more information about changing the appearance of a
map, see theMapsmanual.

l The Filters pane for a map was updated and streamlined, and the counts for each node type now displays in
a badge next to the node type.
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Issues Addressed in 8.12.1

l You can access the Design pane and Filters pane from the new Settings drop-down on the navigation bar
in aMaps window.

l You can hover over a node in a map to view a pop-up Properties pane with the relevant details, or
metadata, for that node. If you click to select a node and then click the [Selections] button, the metadata
displays in a Properties pane to the right of the map.

l If you select a node in a map, you can click the [Events] tab in the Properties pane to monitor the events on
that node. If you do not have the relevant permissions for viewing events, the [Events] tab does not appear.

l For a Service node or an Application node, the Availability, Health, and Risk values now appear on the
Properties pane.

l You can use the Search field at the top of a map page to search for specific nodes on the current map.
Nodes that do notmeet the search criteria are grayed out in the map.

l The Zoom feature for viewing a map was updated to ensure that the node details display clearly when
zooming in or out.

l On the [Nodes] tab of the Design pane, if you have the Show External Labels toggle selected, you can
expand the Label Fields section and edit the type of label that displays under each node. For example, you
could edit the external labels to display the organization name for each node.

l Just like Dashboards, any Maps that you create can be Private (viewable only to you), Public (viewable to
users in all organizations using SL1), or viewable by Specific Organizations. You must have the relevant
permissions to create a map, and the state of a new map is Private by default.

l Depending on the permissions assigned to users, some users will be able to create and edit maps and select
the default layout. Meanwhile, other users will only be able to view and filter existing maps and update the
layout of existing maps.

l To create a copy of an existing map, open the map, click the Save Map drop-down, and select Save As
Copy.

Issues Addressed in 8.12.1

The following issues are addressed in the 8.12.1 Unified UI:

NOTE: The Unified UI includes pages from the SL1 Classic UI, displayed in either the SL1 Classic UI and
ported to the SL1 Next UI.

Asset Records

l The BIOS/EPROM field in the Asset Configuration page (Registry > Assets > Asset Manager > create/edit >
Configuration) can now include up to 64 characters. (Support ID: 177307)(case 00022795)

Collector Groups

l In the Collector Group Management page (System > Settings > Collector Groups), renamed the fieldMax
Allowed Collector Outage toCollectors Available For Failover and addressed an issue where SL1 was
not following the failover rules defind in this page.. If Collector Failover is enabled, and the number of
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Issues Addressed in 8.12.1

available Data Collection servers is less than the value in the Collectors Available For Failover field, SL1 will
not failover within the Collector Group.

Dashboards

l The onboarding dashboard now tries authenticating with the "EM7 internal" method first and no longer
displays spurious errors about LDAP authentication. (Support ID: 175680)(case 20793)

l Dashboard widgets of type iframe that use host name-base proxies now load without security errors. (Support
ID: 177222) (case 24860)

NOTE: If you have enabled the Force Secure HTTPS field in the Behavior Settings page (System > Settings >
Behavior), when you supply a URL in the iframe widget, that URL must also use HTTPS. If you chose
not to enable Force Secure HTTPS field in the Behavior Settings page (System > Settings >
Behavior), you can use HTTP in the iframe widget and perform the following security work-around: `

1. Either go to the console of the Database Server or All-In-One appliance or open an SSH session to he
Database Server or All-In-One appliance.

2. Use vi to edit the file /etc/nginx/conf.d/sm7ngx_web_ui.conf

3. After the last `listen` directive, add the following lines:

{code}
if ($scheme = http) {
return 301 https://$host$request_uri;
}
{code}

Documentation

l Edited the Installation and Initial Configuration manual. Edited the chapter for the PhoneHome configuration.
(Support ID: 108082)

l Edited the Discovery and Credentials manual. Added Caution text that states that if you enter both the
hostname and IP address of the same device, SL1 will discover two duplicate devices. (Support ID: 175871)
(case 21902)

l Edited the System Administration manual, the Device Management manual and the Discovery and
Credentials manual. The Ping and Poll Timeout field has been edited to include both discovery and
availability monitoring. (case 0029032) (Support ID: 177881)

l Edited the System Administration manual. Added a new section on Disabling phpMyAdmin, with updated
steps. (Support ID: 177863) (case 28748)

l The release notes for 8.12.1 and the System Administrators manual now specify that to apply updates to an
existing Data Collector, that Data Collector must be a member of a Collector Group. (Support ID: 176540)
(case 24412)

l I would tell you an IPv4 joke, but all the good ones have been exhausted.

Dynamic Applications
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Issues Addressed in 8.12.1

l Fixed problems with auto-disabling and auto-enabling of collection for collection objects. In the Dynamic
Application Manager page, ( System> Manage > Applications) the Subscribers column now accurately
displays the number of subscribed devices. ( Case 00025077) (Support ID: 152484) (Support ID: 176929)
(Support ID: 159436)

IT Service Policies

l If one or more devices in an IT Service policy go into maintenance mode, with collection enabled, SL1 will
continue aggregating health metrics for those devices, and those devices will not appear as unavailable to
the IT Service. (Support ID: 176826) (case 25061)

Network Interfaces

l When an interface switches between 32-bit counters and 64-bit counters, SL1 will manage the new counter-
value and will not produce unrealistic spikes in bandwidth usage. Bandwidth graphs, reports, and events will
no longer show spikes in bandwidth usage when an interface switches counter type. (Support ID: 173458)
(case 6457) (case 14275) (case 17686) (case 13677) (case 15309) (case 21949) (case 21489) (case
28186)

l All interface data (bandwidth, errors & discards, and packets) is now successfully collected with all possible
combinations of Enable Variable Rate Interface Counters (in System > Settings > Behavior) and high_
precision_if_collect (manually set in master.system_custom_config set field_value). (Support ID: 177371)
(case 28392) (Support ID: 174594) (case 12174) (case 24323) (Support ID:174400) (case 15574)

l The SL1 process "Data Collection: Interface Bandwidth: no longer generates an unhandled exception when
one or more network aliases include a forward-slash character ("/"). (Support ID: 160981) ( case
00026692)

PhoneHome

l In a High Availability system, only the Database Server that is also the PhoneHome control node may
generate a PhoneHome token for the Data Collectors. (Support ID: 153173) ( Support ID: 161661)(Support
ID: 172370)(Case 00006471)

Security

l All SL1 cookies now have their secure flag set to "yes". (Support ID: 177838) (Case 29364)

l The page <ip address>/em7/license.html no longer allows page caching. (Support ID: 177837) (case
00029365)

SNMP Traps

l If you create a trap filter in the SNMP Trap Filter page ( Registry > Events > SNMP Trap Filters) and specify a
value only in the Trap OID Filter field (and specify no values in the Varbind OID Filter field or the Varbind
OID Pattern field), SL1 will successfully filter traps with a matching OID. When a trap is filtered, the Message
Collector receives the trap, but does not store the trap, does not act on the trap, and does not pass the trap on
to be examined by the ScienceLogic event engine.(Support ID: 178728) (Case 35100)

System Update

l The database processes that occur during system update and that were affecting high-frequency collection
and medium-frequency collection have been improved for better performance. (Support ID: 178910) (Case
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PowerPacks Released with 8.12.1

38635 )

ScienceLogic API

l GQL queries and REST API queries for device relationships no longer run slowly, cause timeouts, and affect
the performance of the Database Server. (Support ID: 178242) (case 00031725)

l You can now successfully create and update an asset record with a POST method. (Support ID:178837)
(case 37845)

The following issues are addressed in the 8.12.1 Next UI:

NOTE: Features in this section are not available in the SL1 Classic UI.

General

l Addressed an issue to ensure that SL1 properly handles user passwords with special characters such as "%"
and "@".

l Addressed an issue where the Search feature did not provide results when searching for Custom Attribute
labels or values.

Business Services

l Addressed an issue where the [Overview] page for a Device Service displayed an empty set of devices,
stating that "Selected device services do not currently contain devices."

PowerPacks Released with 8.12.1

When patching to 8.12.1, please verify whether any PowerPacks that your system is currently running are “newer”
than the PowerPacks included in this SL1 update. If the PowerPack on your system is "newer" than the one included
with the SL1 update, you might see spurious error messages. To avoid spurious error messages:

1. Go to the Device Components page (Registry > Devices > Device Components).

2. Find each root device associated with the PP you do not want to update and select its checkbox.

3. Click the Select Action field and choose Change Collection State: Disabled (recursive). Click the [Go]
button.

4. Wait five minutes after disabling collection.

5. install the SL1 update.

6. Go to the Device Components page (Registry > Devices > Device Components).

7. Select the checkbox for all affected root devices.

8. In the Select Actions drop-down list, select Change Collection State: Enabled (recursive).

9. Click the [Go] button.

The 8.12.1 release includes the following PowerPacks that are new or updated and included with the release:
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New and Updated Packages in 8.12.1

l Net-SNMP Base pack, v101

l F5 BIG-IP, v102

Documentation and release notes for each PowerPack are available on the ScienceLogic Portal.

CAUTION: If you are currently using the Amazon Web Services PowerPack included in the 8.1.0 platform
release or included in an earlier platform release, please read the release notes for Amazon Web
Services before migrating to later versions Amazon Web Services PowerPack. You must first
migrate to Amazon Web Services, v100 before upgrading to later versions of the Amazon Web
Services.

CAUTION: If you are currently using the VMware: vSphere Base Pack, v202 or earlier, please read the
migration instructions in the release notes for VMware: vSphere Base Pack, v203 and migrate to
v203 before upgrading to later versions of the PowerPack.

NOTE: The "Microsoft SharePoint" PowerPack is no longer included with platform releases. The PowerPack is
superseded by the "Microsoft: SharePoint Server" PowerPack.

NOTE: The "Microsoft SQL Server" PowerPack is no longer included with platform releases. The PowerPack is
superseded by the "Microsoft: SQL Server" and "Microsoft: SQL Server Enhanced" PowerPacks.

NOTE: The "Microsoft Exchange" PowerPack is no longer included with platform releases. The PowerPack is
superseded by the "Microsoft: Exchange Server 2010" and "Microsoft: Exchange Server 2013"
PowerPacks.

NOTE: The "Microsoft HyperV" PowerPack is no longer included with platform releases. The PowerPack is
superseded by the PowerPack "Microsoft: Hyper-V Server".

New and Updated Packages in 8.12.1

The 8.12.1 release includes multiple kernel updates and security updates. These important security updates
will not take effect until each appliance in your system is rebooted. If you would like assistance in
planning an upgrade path that meets your security needs while minimizing downtime, please contact
your Customer Success Manager.

Beta Features

The following beta features are included in the 8.12.1 release:
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Beta Features

l Manual Device Discovery

o This beta feature allows monitored devices to be added manually instead of via a discovery session.

l Run Book Actions: Custom Action Type

l A Run Book Action of type "Custom Action Type" executes a reusable snippet. Unlike the Action Type
"Snippet", a Custom Action Type can accept input parameters (in a JSON format) and create output
(in a JSON format). A Custom Action Type allows a single snippet to be used in multiple Action
Policies, each time with different inputs and different outputs. A Custom Action Type is associated with
an Execution Environment. An Execution Environment contains the supporting modules and code
(Content Libraries) required by the Custom Action Type. Content Libraries allow snippet developers to
isolate the “heavy weight”, re-usable code and write “light weight” snippets that call the Content
Libraries.

l PowerPacks: Beta versions of the following PowerPacks are available. You can download then from the
Customer Portal and import them into SL1:

o Alibaba Cloud: Aliyun

o AMQP: RabbitMQ

o Cisco: ACI Multi-Site Manager

o Cisco: Cloud Center

o Cisco: Contact Center Enterprise

o Cisco: Hyperflex

o Cisco: Medianet/Mediatrace

o Cisco: Meraki (API)

o Cisco: Tetration

o Cisco: UC Ancillary PowerPack. Includes Dynamic Applications for monitoring Cisco CUBE devices.

o Cisco: UCS Director

o Cisco: Unity Express (Download from the Customer Portal and Import into SL1)

o Docker (Download from the Customer Portal and Import into SL1)

o ELK: AWS CloudTrail

o ELK: Azure Activity Log

o F5: BIG-IP DNS

o Google Cloud Platform

o Hitachi Data Systems: VSP

o Kubernetes

o Link Layer Neighbor Discovery (Download from the Customer Portal and Import into SL1)

o Microsoft: Office 365

o Microsoft: Windows Server Event Logs

o Palo Alto (Download from the Customer Portal and Import into SL1)
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Disabling the Knowledge Base

To install a beta PowerPack:

1. Go to the PowerPack Manager page (System > Manage > PowerPacks).

2. Select the [Actions]menu and select Install PowerPack. The PowerPack Installermodal page is displayed.

3. Select the lightning-bolt icon ( ) for the PowerPack you want to install. Information about the contents of the
PowerPack and the installation process is displayed.

4. Select the [Install] button.

TIP: By default, installing an updated version of a PowerPack will overwrite all content in a PowerPack that has
already been installed on the target system. You can use the Enable Selective PowerPack Field
Protection setting in the Behavior Settings page (System > Settings > Behavior) to prevent new
PowerPacks from overwriting local changes for some commonly customized fields.

Disabling the Knowledge Base

The Knowledge Base includes known security vulnerabilities. ScienceLogic no longer supports the Knowledge
Base

l ScienceLogic strongly recommends that existing users disable the Knowledge Base. 8.9.2 and later releases
provides a new setting in the silo.conf file to disable the Knowledge Base.

l For new installations that installed 8.12.1, the Knowledge Base will be disabled by default.

WARNING: The Knowledge Base includes known vulnerabilities for cross-site scripting and SQL injection.
ScienceLogic strongly recommends that you disable the Knowledge Base.

To disable the Knowledge Base:

1. Use SSH to connect to the Administration Portal and Database Server or All-In-One (all SL1
appliances that provide a web interface).

2. Use an editor like vi and edit the file /etc/silo.conf. In the LOCAL section, add the line:

kbase_disabled=1

4. Use an editor like vi and edit the file /etc/siteconfig/siloconf.siteconfig. In the LOCAL section, add
the line:

kbase_disabled=1

5. Open a browser session and login to the SL1

6. From the hamburger menu ( ) in the upper right, select Clear SL1 System Cache.

7. Upon your next login, the Knowledge Base tab will not appear. Attempts to access the tab will result in
an "Access Denied" error message.
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Special Upgrade Process for FIPS-Compliant System

FIPS-compliant systems should use the classic SL1 user interface. The Unified User Interface is not yet FIP-
compliant.

FIPS-compliant systems (those that are FIPS 140-2 enabled) shouldmanually upgrade to the latest version of
MariaDB.

The platform patch will automatically update MariaDB-client, MariaDB-common, and MariaDB-shared RPMs but
will not update the MariaDB Server.

Special Considerations for Systems Running 8.4.1 or Earlier

WARNING: 8.10.0 and later releases do not support Data Collectors and Message Collectors
running the CentOS operating system. If your system includes Data Collectors and
Message Collectors running the CentOS operating system, contact your Customer
Success Manager for details on upgrading Data Collectors and Message Collectors to
Oracle Linux before installing 8.12.1.

8.4.2 included a new feature for Ticketing. The Note Editor for tickets includes a drop-down menu where the user
can specify that the note be saved as Plain Text or HTML. Ticket notes created in the API can also be saved as Plain
Text or HTML. HTML is the default format for ticket notes in both the Note Editor and the API.

This new feature required a change to the database schema that will be performed immediately after a system is
upgraded to 8.4.2 or later for the first time. If your system has not been upgraded to 8.4.2 or later, this schema
change will be performed after you upgrade.

During the post-patch process, all existing ticket notes will be migrated to the new schema in batches. During the
migration, all ticket notes will be unavailable. The user interface and API will not display ticket notes. Ticket notes
cannot be viewed or updated during the post-patch process. On a system that included 2,000,000 ticket notes,
this process took approximately 6 hours.

If you require access to all ticket notes immediately after installing an 8.4.2 or later release, contact
ScienceLogic Customer Support for details on manually updating the database schema before you
upgrade to 8.4.2 or later.

The 8.4.2 release also changed the firewall on all appliances from iptables to firewalld. If you are currently
running a release earlier than 8.4.2 and have added one or more custom firewall rules, such as a non-standard
port for Phone Home Collectors, these rules must be migrated before upgrading to 8.8.1. Please contact
ScienceLogic Support for more information.
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Upgrade Process for 7.x Systems

WARNING: 8.10.0 and later releases do not support Data Collectors and Message Collectors
running the CentOS operating system. If your system includes Data Collectors and
Message Collectors running the CentOS operating system, contact your Customer
Success Manager for details on upgrading Data Collectors and Message Collectors to
Oracle Linux before installing 8.12.0.

WARNING: 7.x systems must be upgraded to 7.8.5 before migration to the 8.9.0 release (using a special
migration patch). After migration to 8.9.0, users can upgrade to releases later than 8.9.0.
Upgrading to 8.10.0 and later requires re-building all Data Collectors and Message Collectors.
Please contact your Customer Success Manager to begin a discussion on the migration plan that
is appropriate for your system.

The 8.1.1 release included a complete update of the ScienceLogic appliance operating system from CentOS
5.11 to Oracle Linux. Major operating system components, including the database, web server, and High
Availability/Disaster Recovery packages have been updated or replaced by new industry-standard packages.

When upgrading from version 7.8.5 to version 8.9.0, each appliance must be migrated to 8.9.0 and the Oracle
Linux 7.5 operating system.

Upgrade from 7.x to 8.9.0

WARNING: ScienceLogic strongly suggest you contact Customer Support or your Customer Success
Manager to plan your migration from CentOS (versions of SL1 prior to 8.1.1) to 8.9.0.

The process of migrating an existing system to 8.9.0 includes multiple additional steps that will vary depending on
the current architecture. Please contact your Customer Success Manager to begin a discussion on the migration
plan that is appropriate for your system.

The following is the general process for migrating from 7.x to 8.9.0. This is a high-level description only. For
details, contact Customer Support or your Customer Success Manager.

l The existing system must be upgraded to 7.8.5 before the upgrade.

l Run the 8.9.0 migration patch.

NOTE: See the separate Migration document for detailed instructions on how to perform the migration steps.
Before you migrate to 8.9.0, please contact your Customer Success Manager.
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l Use the 8.9.0 ISO to reinstall all Database Servers or All-In-One Appliances. Data is migrated using a
logical backup while the database on the existing system is stopped. The downtime of this operation can be
mitigated in several ways depending on the current architecture.

l Use the 8.9.0 ISO to reinstall all Administration Portal appliances.

l After reinstalling all Database Servers and Administration Portals, the system is operational and can be
upgraded.

l To upgrade to 8.12.1, see the section on Upgrade Process for Systems Running 8.4.0 and Later.

Features Not Current ly Supported by the 8.x Releases

The following functionality that was available in previous releases is not currently available in the 8.12.0 release,
but will be re-added in a future release:

l Configuring two All-In-One Appliances for Disaster Recovery

l Applying a patch manually with the apply_patch script
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Upgrade Process for Systems Running 8.4.0 and Later

WARNING:Do not import 8.12.0 or 8.12.1 if you do not plan to immediately consume the 8.12.x
line of releases. After you import an 8.12.0 release, all appliances in your SL1 system will now
use the new system update. After you import an 8.12.0 release, you will not be able to stage
and deploy any versions of SL1 previous to 8.12.0 or apply patches to versions of SL1 previous to
8.12.0.

WARNING: To install 8.12.1 and new SystemUpdates tool, you have must have already imported,
staged, and deployed 8.4.0

WARNING: 8.10.0 and later releases do not support Data Collectors and Message Collectors
running the CentOS operating system. If your system includes Data Collectors and
Message Collectors running the CentOS operating system, contact your Customer
Success Manager for details on upgrading Data Collectors and Message Collectors to
Oracle Linux before installing 8.12.1.

WARNING: 8.12.1 includes important security updates that require you to reboot all appliances
after installing 8.12.1. If you would like assistance in planning an upgrade path that meets your
security needs while minimizing downtime, please contact your Customer Success Manager.

WARNING: If your system is not currently running a recent release, the upgrade process includes importing
multiple upgrade files (8.5.0 > 8.6.0 > 8.7.0 > 8.8.0 > 8.9.0 > 8.10.0 > 8.12.0 >
8.12.1). You must wait until an update file has imported successfully (when the Import Status
column displays Complete) before importing the next update file.

WARNING: To apply updates to an existing Data Collector, that Data Collector must be a member of a
Collector Group. In some SL1 systems, users might have to create a Collector Group for a single
Data Collector before applying updates.

CAUTION: ScienceLogic recommends that Systems running an AP2 version earlier than 5.55.1.3 upgrade
via GQL before upgrading to 8.12.1.

To upgrade to the 8.12.1 release from an 8.4.0 or later release:
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NOTE: Before upgrading, ensure that:

l Each SL1 Appliance has a valid license

l Each Data Collector is a member of a Collector Group

l Each Data Collector is "available" to the Database Server. To check, see the Collector Status page
(System > Monitor > Collector Status).

NOTE: Staging and deploying SL1 patches is "hitless" and does not require a maintenance window.

1. Familiarize yourself with the Known Issues for this release.

2. For systems running an SL1 version prior to 8.12.0, go to the System Updates page and disable automatic
staging (System > Tools > Updates > Actions > Disable automatic staging).

l If you have previously used manual staging, perform these additional steps:

o Go to the System Updates page (System > Tools > Updates). Select all updates in the EM7
Releases pane and select all updates in the ScienceLogic OS pane.

o In the Select Action menu, select Unstage Update (remove staging policy override). Click [Go].

o For software that was previously staged with automatic staging, Unstage Update (remove staging
policy override) does not affect staging.

NOTE: For details on downloading, importing, staging, and installing system updates, see the manual System
Administration.

3. If you are currently running an 8.4 release:

l From the ScienceLogic portal, download the latest update for 8.5.0, 8.6.0, 8.7.0, 8.8.0, 8.9.0,
8.10.0, 8.12.0, and 8.12.1 to a local computer. Unzip any zipped files.

l Import the 8.5.0 system update file in the System Updates page (System > Tools > Updates >
[Import] button). The system update file will load an update in both the EM7 Releases and the
ScienceLogic OS section. You must wait until the update file has imported successfully (i.e. the Import
Status column displays Complete) before importing the next update file.
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l Import the 8.6.0 system update file in the System Updates page (System > Tools > Updates >
[Import] button). The system update file will load an update in both the EM7 Releases and the
ScienceLogic OS section. You must wait until the update file has imported successfully (i.e. the Import
Status column displays Complete) before importing the next update file.

l Import the 8.7.0 system update file in the System Updates page (System > Tools > Updates >
[Import] button). The system update file will load an update in both the EM7 Releases and the
ScienceLogic OS section. You must wait until the update file has imported successfully (i.e. the Import
Status column displays Complete) before importing the next update file.

l Import the 8.8.0 system update file in the System Updates page (System > Tools > Updates >
[Import] button). The system update file will load an update in both the EM7 Releases and the
ScienceLogic OS section. You must wait until the update file has imported successfully (i.e. the Import
Status column displays Complete) before importing the next update file.

l Import the 8.9.0 system update file in the System Updates page (System > Tools > Updates >
[Import] button). The system update file will load an update in both the EM7 Releases and the
ScienceLogic OS section. You must wait until the update file has imported successfully (i.e. the Import
Status column displays Complete) before importing the next update file.

l Import the 8.10.0 system update file in the System Updates page (System > Tools > Updates >
[Import] button). The system update file will load an update in both the EM7 Releases and the
ScienceLogic OS section. You must wait until the update file has imported successfully (i.e. the Import
Status column displays Complete) before importing the next update file.

l Import the 8.12.0 system update file in the System Updates page (System > Tools > Updates >
[Import] button). You must wait until the update file has imported successfully (i.e. the Import Status
column displays Complete) before importing the next update file.

l Go to step #11 and continue.

4. If you are currently running an 8.5 release:

l From the ScienceLogic portal, download the latest update for 8.6.0, 8.7.0, 8.8.0, 8.9.0, 8.10.0,
8.12.0, and 8.12.1 to a local computer. Unzip any zipped files.

l Import the 8.6.0 system update file in the System Updates page (System > Tools > Updates >
[Import] button). The system update file will load an update in both the EM7 Releases and the
ScienceLogic OS section. You must wait until the update file has imported successfully (i.e. the Import
Status column displays Complete) before importing the next update file.

l Import the 8.7.0 system update file in the System Updates page (System > Tools > Updates >
[Import] button). The system update file will load an update in both the EM7 Releases and the
ScienceLogic OS section. You must wait until the update file has imported successfully (i.e. the Import
Status column displays Complete) before importing the next update file.

l Import the 8.8.0 system update file in the System Updates page (System > Tools > Updates >
[Import] button). The system update file will load an update in both the EM7 Releases and the
ScienceLogic OS section. You must wait until the update file has imported successfully (i.e. the Import
Status column displays Complete) before importing the next update file.

l Import the 8.9.0 system update file in the System Updates page (System > Tools > Updates >
[Import] button). The system update file will load an update in both the EM7 Releases and the
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ScienceLogic OS section. You must wait until the update file has imported successfully (i.e. the Import
Status column displays Complete) before importing the next update file.

l Import the 8.10.0 system update file in the System Updates page (System > Tools > Updates >
[Import] button). The system update file will load an update in both the EM7 Releases and the
ScienceLogic OS section. You must wait until the update file has imported successfully (i.e. the Import
Status column displays Complete) before importing the next update file.

l Import the 8.12.0 system update file in the System Updates page (System > Tools > Updates >
[Import] button). You must wait until the update file has imported successfully (i.e. the Import Status
column displays Complete) before importing the next update file. After 8.12.0 has been imported,
refresh the System Updates page to view the new user interface for the page.

l Go to step #11 and continue.

5. If you are currently running an 8.6 release:

l From the ScienceLogic portal, download the latest update for 8.7.0, 8.8.0, 8.9.0, 8.10.0, 8.12.0,
and 8.12.1 to a local computer. Unzip any zipped files.

l Import the 8.7.0 system update file in the System Updates page (System > Tools > Updates >
[Import] button). The system update file will load an update in both the EM7 Releases and the
ScienceLogic OS section. You must wait until the update file has imported successfully (i.e. the Import
Status column displays Complete) before importing the next update file.

l Import the 8.8.0 system update file in the System Updates page (System > Tools > Updates >
[Import] button). The system update file will load an update in both the EM7 Releases and the
ScienceLogic OS section. You must wait until the update file has imported successfully (i.e. the Import
Status column displays Complete) before importing the next update file.

l Import the 8.9.0 system update file in the System Updates page (System > Tools > Updates >
[Import] button). The system update file will load an update in both the EM7 Releases and the
ScienceLogic OS section. You must wait until the update file has imported successfully (i.e. the Import
Status column displays Complete) before importing the next update file.

l Import the 8.10.0 system update file in the System Updates page (System > Tools > Updates >
[Import] button). The system update file will load an update in both the EM7 Releases and the
ScienceLogic OS section. You must wait until the update file has imported successfully (i.e. the Import
Status column displays Complete) before importing the next update file.

l Import the 8.12.0 system update file in the System Updates page (System > Tools > Updates >
[Import] button). You must wait until the update file has imported successfully (i.e. the Import Status
column displays Complete) before importing the next update file. After 8.12.0 has been imported,
refresh the System Updates page to view the new user interface for the page.

l Go to step #11 and continue.
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6. If you are currently running an 8.7 release:

l From the ScienceLogic portal, download the 8.8.0, 8.9.0, 8.10.0, 8.12.0, and 8.12.1 updates to a
local computer. Unzip any zipped files.

l Import the 8.8.0 system update file in the System Updates page (System > Tools > Updates >
[Import] button). The system update file will load an update in both the EM7 Releases and the
ScienceLogic OS section. You must wait until the update file has imported successfully (i.e. the Import
Status column displays Complete) before importing the next update file.

l Import the 8.9.0 system update file in the System Updates page (System > Tools > Updates >
[Import] button). The system update file will load an update in both the EM7 Releases and the
ScienceLogic OS section. You must wait until the update file has imported successfully (i.e. the Import
Status column displays Complete) before importing the next update file.

l Import the 8.10.0 system update file in the System Updates page (System > Tools > Updates >
[Import] button). The system update file will load an update in both the EM7 Releases and the
ScienceLogic OS section. You must wait until the update file has imported successfully (i.e. the Import
Status column displays Complete) before importing the next update file.

l Import the 8.12.0 system update file in the System Updates page (System > Tools > Updates >
[Import] button). You must wait until the update file has imported successfully (i.e. the Import Status
column displays Complete) before importing the next update file. After 8.12.0 has been imported,
refresh the System Updates page to view the new user interface for the page.

l Continue to step #11.

7. If you are currently running an 8.8 release:

l From the ScienceLogic portal, download the 8.9.0, 8.10.0, 8.12.0, and 8.12.1 updates to a local
computer. Unzip any zipped files.

l Import the 8.9.0 system update file in the System Updates page (System > Tools > Updates >
[Import] button). The system update file will load an update in both the EM7 Releases and the
ScienceLogic OS section. You must wait until the update file has imported successfully (i.e. the Import
Status column displays Complete) before importing the next update file.

l Import the 8.10.0 system update file in the System Updates page (System > Tools > Updates >
[Import] button). The system update file will load an update in both the EM7 Releases and the
ScienceLogic OS section. You must wait until the update file has imported successfully (i.e. the Import
Status column displays Complete) before importing the next update file.

l Import the 8.12.0 system update file in the System Updates page (System > Tools > Updates >
[Import] button). You must wait until the update file has imported successfully (i.e. the Import Status
column displays Complete) before importing the next update file. After 8.12.0 has been imported,
refresh the System Updates page to view the new user interface for the page.

l Go to step #11 and continue.

8. If you are currently running an 8.9 release:

l From the ScienceLogic portal, download the 8.10.0, 8.12.0, and 8.12.1 updates to a local
computer. Unzip any zipped files.

l Import the 8.10.0 system update file in the System Updates page (System > Tools > Updates >
[Import] button). The system update file will load an update in both the EM7 Releases and the
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ScienceLogic OS section. You must wait until the update file has imported successfully (i.e. the Import
Status column displays Complete) before importing the next update file.

l Import the 8.12.0 system update file in the System Updates page (System > Tools > Updates >
[Import] button). You must wait until the update file has imported successfully (i.e. the Import Status
column displays Complete) before importing the next update file. After 8.12.0 has been imported,
refresh the System Updates page to view the new user interface for the page.

l Go to step #11 and continue.

9. If you are currently running an 8.10 release:

l From the ScienceLogic portal, download the 8.21.0 and 8.12.1 updates to a local computer. Unzip
any zipped files.

l Import the 8.12.0 system update file in the System Updates page (System > Tools > Updates >
[Import] button). You must wait until the update file has imported successfully (i.e. the Import Status
column displays Complete) before importing the next update file. After 8.12.0 has been imported,
refresh the System Updates page to view the new user interface for the page.

l Go to step #11 and continue.

10. If you are currently running the 8.12.0 release or an 8.12.0.x release:

l From the ScienceLogic portal, download the 8.12.1 update to a local computer. Unzip any zipped
files.

l Go to step #11 and continue.

11. Import the 8.12.1 system update file in the System Updates page (System > Tools > Updates > [Import]
button).

12. Select the staging icon ( ) for 8.12.1.

13. When staging has completed, select the lightning-bolt icon ( ) to deploy 8.12.1.

14. Clear your browser's cache.

15. Clear the SL1 cache.

l Go to the CacheManagement page (System > Tools > Cache).

l From the hamburger menu ( ), select Clear EM7 System Cache.

CAUTION: An update in 8.12.1 requires that you clear the EM7 System Cache. Until you clear the EM7
System Cache, you might experience errors with credentials that can affect discovery, calls to the
the ScienceLogic API, and calls to GQL.

17. If you have not previously upgraded to 8.2.0, perform the steps listed in theOther Manual Updates
section.

18. Go to the PowerPack Manager page (System > Manage > PowerPacks) and install all updated
PowerPacks. Updated PowerPacks are loaded on your ScienceLogic system by the patch process. To install
an updated PowerPack, find the PowerPack in the PowerPack Manager page and select the installation
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icon ( ) in the Update column for the PowerPack or use the Update PowerPacks option in the Select
Action drop-down list.

TIP: By default, installing an updated version of a PowerPack will overwrite all content in that PowerPack that
has already been installed on the target system. You can use the Enable Selective PowerPack Field
Protection setting in the Behavior Settings page (System > Settings > Behavior) to prevent new
PowerPacks from overwriting local changes for some commonly customized fields.

19. If you are monitoring devices using the ScienceLogic Agent, follow the steps listed in the Agent Monitoring
manual to upgrade to the latest version of the Agent.

CAUTION:Upgrading MariaDB and the rebooting all SL1 appliances should be performed during a
maintenance window. If you would like assistance in planning an upgrade path that minimizes
downtime, please contact your Customer Success Manager.

20. Upgrade MariaDB to the latest version. To do so, perform the steps in the Upgrading MariaDB section.

21. 8.12.1 includes important security updates that require you to reboot all appliances after installing
8.12.1. If you would like assistance in planning an upgrade path that meets your security needs while
minimizing downtime, please contact your Customer Success Manager.

Upgrading MariaDB

Version 8.12.0 requires updates to MariaDB that address security and performance issues. You can download the
latest approved MariaDB updates at https://portal.sciencelogic.com/portal/miscellaneous.

NOTE: To address security issues, download the latest MariaDB updates. Earlier MariaDB updates remain on
the portal to support users who have not yet migrated to the latest release.

The following sections describe how to perform this upgrade for different appliance types and architectures.

Two Database Servers Configured for High Availability

To upgrade a High Availability cluster, perform the following steps:

WARNING: The system will be unavailable when performing these steps.

1. Copy the MariaDB RPMs to the file system of both appliances.

2. Log in to the command-line of both Database Server appliances as em7admin.

3. Execute the following command on the secondary Database Server:
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sudo systemctl stop pacemaker.service

4. Execute the following command on the primary Database Server to determine the current installed version of
the RPMs:

sudo rpm -qa ^MariaDB-*

5. Execute the following command on the primary Database Server:

sudo systemctl stop mysql

6. On the primary Database Server, navigate to the directory that you copied the RPMs.

7. For each RPM that the output from step 5 showed at an earlier version, execute the following command on
the primary Database Server:

sudo rpm -Uvh <file name of RPM>

8. Execute the following command on the primary Database Server to validate that the RPMs installed correctly:

sudo rpm -qa ^MariaDB-*

9. Execute the following command on the primary Database Server:

sudo systemctl start mysql

10. Execute the following command on the primary Database Server, replacing the password for the root
database user when prompted:

sudo mysql_upgrade -u root -p

11. On the secondary Database Server, execute the following command to determine the current installed
version of the RPMs:

sudo rpm -qa ^MariaDB-*

12. On the secondary Database Server, navigate to the directory where you copied the RPMs.

13. For each RPM that the output from step 11 showed at an earlier version of MariaDB, execute the following
command on the secondary Database Server:

sudo rpm -Uvh <file name of RPM>

14. Execute the following command on the secondary Database Server to validate that the RPMs installed
correctly:

sudo rpm -qa ^MariaDB-*

15. Execute the following command on the secondary Database Server:

sudo systemctl start pacemaker.service
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Two Database Servers Configured for Disaster Recovery

To upgrade two Database Servers configured for disaster recovery, perform the following steps:

WARNING: The system will be unavailable when performing these steps.

1. Copy the latest RPMs to the file system of both appliances.

2. Log in to the command-line of both Database Server appliances as em7admin.

3. Execute the following command on the primary Database Server to determine the current installed version of
the RPMs:

sudo rpm -qa ^MariaDB-*

4. Execute the following command on the primary Database Server:

sudo systemctl stop mysql

5. On the primary Database Server, navigate to the directory that you copied the RPMs.

6. For each RPM that the output from step 4 showed at an earlier version, execute the following command on
the primary Database Server:

sudo rpm -Uvh <file name of RPM>

7. Execute the following command on the primary Database Server to validate that the RPMs installed correctly:

sudo rpm -qa ^MariaDB-*

8. Execute the following command on the primary Database Server:

sudo resource start mysql

9. Execute the following command on the primary Database Server, replacing the password for the root
database user where indicated:

sudo mysql_upgrade -u root -p

10. On the secondary Database Server, execute the following command to determine the current installed
version of the RPMs:

sudo rpm -qa ^MariaDB-*

11. On the secondary Database Server, navigate to the directory where you copied the RPMs.

12. For each RPM that the output from step 10 showed at an earlier version, execute the following command on
the secondary Database Server:

sudo rpm -Uvh <file name of RPM>

13. Execute the following command on the secondary Database Server to validate that the RPMs installed
correctly:

sudo rpm -qa ^MariaDB-*
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Three Database Servers Configured for HA and DR

To upgrade a High Availability cluster, perform the following steps:

WARNING: The system will be unavailable when performing these steps.

1. Copy the latest RPMs to the file system of all three appliances.

2. Log in to the command-line of all three Database Server appliances as em7admin.

3. Execute the following command on the secondary Database Server in the HA cluster:

sudo systemctl stop pacemaker.service

4. Execute the following command on the primary Database Server in the HA cluster to determine the current
installed version of the RPMs:

sudo rpm -qa ^MariaDB-*

5. Execute the following command on the primary Database Server in the HA cluster:

sudo systemctl stop mysql

6. On the primary Database Server in the HA cluster, navigate to the directory that you copied the RPMs.

7. For each RPM that the output from step 5 showed at an earlier version, execute the following command on
the primary Database Server in the HA cluster:

sudo rpm -Uvh <file name of RPM>

8. Execute the following command on the primary Database Server in the HA cluster to validate that the RPMs
installed correctly:

sudo rpm -qa ^MariaDB-*

9. Execute the following command on the primary Database Server in the HA cluster:

sudo systemctl start mysql

10. Execute the following command on the primary Database Server in the HA cluster, replacing the password for
the root database user where indicated:

sudo mysql_upgrade -u root -p

11. On the secondary Database Server, execute the following command to determine the current installed
version of the RPMs:

sudo rpm -qa ^MariaDB-*

12. On the secondary Database Server, navigate to the directory where you copied the RPMs.

13. For each RPM that the output from step 11 showed at an earlier version, execute the following command on
the secondary Database Server:

sudo rpm -Uvh <file name of RPM>
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14. Execute the following command on the secondary Database Server in the HA cluster to validate that the RPMs
installed correctly:

sudo rpm -qa ^MariaDB-*

15. Execute the following command on the secondary Database Server in the HA cluster:

sudo systemctl start pacemaker.service

16. On the Database Server for disaster recovery, execute the following command to determine the current
installed version of the RPMs:

sudo rpm -qa ^MariaDB-*

17. On the Database Server for disaster recovery, navigate to the directory that you copied the RPMs.

18. For each RPM that the output from step 16 showed at an earlier version, execute the following command on
the Database Server for disaster recovery:

sudo rpm -Uvh <file name of RPM>

19. Execute the following command on the secondary Database Server in the HA cluster to validate that the RPMs
installed correctly:

sudo rpm -qa ^MariaDB-*

20. Execute the following command on the Database Server for disaster recovery to validate that the RPMs
installed correctly:

sudo rpm -qa ^MariaDB-*

Single Database Server/All-In-One Appliance/Data
Collector/Message Collector

To upgrade MariaDB on a single Database Server, All-In-One Appliance, Data Collector, or Message Collector,
perform the following steps:

WARNING: The Database Server, All-In-One Appliance, Data Collector, or Message Collector will be
inoperable when performing these steps.

1. Copy the latest RPMs to the file system of the appliance:

2. Log in to the command-line of the appliance as em7admin.

3. Execute the following commands:

sudo systemctl stop em7
sudo systemctl stop mariadb.service

4. Execute the following command to determine the current installed version of the RPMs:

sudo rpm -qa ^MariaDB-*

5. Navigate to the directory that you copied the RPMs.

6. For each RPM that the output from step 4 showed at an earlier version, execute the following command:
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sudo rpm -Uvh <file name of RPM>

7. Execute the following command to validate that the RPMs installed correctly:

sudo rpm -qa ^MariaDB-*

8. Execute the following commands:

sudo systemctl daemon-reload
sudo systemctl start mariadb.service

9. Execute the following command, replacing the password for the root database user where indicated:

sudo mysql_upgrade -u root -p

10. Execute the following command to re-start SL1:

sudo systemctl start em7

Manual Updates for 8.4.x Systems Updated to 8.12.0

If you upgraded from an 8.4.x system to 8.12.0, after 8.12.0 is installed, you must manually apply the following
changes to every Message Collector and All-In-One Appliance in your system:

1. Either go to the console or use SSH to access the server.

2. Log in as user em7admin with the appropriate password.

3. Enter the following at the command line:

sudo vi /etc/siteconfig/siloconf.siteconfig

4. Locate the following line:

eventmanager = syslog,trap,internal

NOTE: On an All-In-One Appliance, this line will include additional entries in the comma-delimited
list.

5. Add ",agent" to the end of the line. The line should now look like this:

eventmanager = syslog,trap,internal,agent

6. Save the file and exit vi (:wq).

7. At the command line, enter the following command to rebuild the configuration file:

sudo /opt/em7/share/scripts/generate-silo-conf.py > /etc/silo.conf

Rebooting Appliances

Use the applicable steps listed in this section to reboot your appliances.
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Administrat ion Portal

If your SL1 system includes multiple Administration Portals, you can remotely reboot Administration Portals from
another Administration Portal. To do so:

1. Go to the Appliance Manager page (System > Settings > Appliances).

2. Select the checkboxes for the appliances you want to reboot.

3. In the [Select Action]menu, select Reboot and click the Go button.

4. Click the OK button when the "Are you sure you want to reboot the selected appliances?" message is
displayed.

5. During the reboot, the user interface for the affected Administration Portals is unavailable.

6. When the reboot has completed, the Audit Logs page (System > Monitor > Audit Logs) will include an entry
for each appliance that was rebooted.

If your SL1 system include only a single Administration Portal, perform the following steps to reboot that
Administration Portal:

1. Either go to the console of the Database Server or use SSH to access the server.

2. Log in as em7admin with the appropriate password.

3. At the shell prompt, execute the following:

python -m silo_common.admin_toolbox <appliance_ID> "/usr/bin/sudo /usr/sbin/shutdown
-r +1"

where:

l appliance_ID is the appliance ID for the Data Collector, Message Collector, or Administration Portal.

Data Collectors and Message Collectors

You can reboot Data Collector and Message Collectors either from the user interface or from the command line.

From the SL1 user interface, perform the following steps to reboot a Data Collector or Message Collector:

1. Go to the Appliance Manager page (System > Settings > Appliances).

2. Select the checkboxes for the appliances you want to reboot.

3. In the [Select Action]menu, select Reboot and click the Go button.

4. Click the OK button when the "Are you sure you want to reboot the selected appliances?" message is
displayed.

5. During the reboot, go to the System Logs page (System > Monitor > System Logs). You should see this
message:

Major: Could not connect to module (5) database USING SSL=TRUE: Error attempting
to connect to database with SSL enabled True: (2003, 'Can't connect to MySQL
server on '10.2.12.77' (113 "No route to host")')
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6. When the reboot has completed, the Audit Logs page (System > Monitor > Audit Logs) will include an entry
for each appliance that was rebooted.

From the console of the Database Server or SSH to the Database Server, perform the following steps to reboot a
Data Collector or Message Collector:

1. Either go to the console of a Database Server or SSH to access the server.

2. Log in as em7admin with the appropriate password.

3. At the shell prompt, execute the following:

python -m silo_common.admin_toolbox <appliance_ID> "/usr/bin/sudo /usr/sbin/shutdown
-r +1"

where:

l appliance_ID is the appliance ID for the Data Collector, Message Collector, or Administration Portal.

Standalone All-In-One Appliances and Database Servers

Perform the following steps to reboot a standalone All-In-One Appliance or Database Server:

1. Either go to the console or use SSH to access the server.

2. Log in as em7admin with the appropriate password.

3. Execute the following commands on the appliance to pause the system and shutdown MariaDB. Enter the
password for the em7admin user when prompted:

sudo touch /tmp/.proc_mgr_pause
sudo systemctl stop mariadb

4. Execute the following command on the appliance to reboot the appliance:

sudo reboot

5. After the appliance has rebooted, log in to the appliance as the em7admin user using the console or SSH.

6. Execute the following command on the appliance to un-pause the system:

sudo rm /tmp/.proc_mgr_pause

7. Enter the password for the em7admin user and confirm the command when prompted.

Two Database Servers Configured for Disaster Recovery

Perform the following steps to reboot two Database Servers configured for Disaster Recovery:

1. Either go to the console of the primary Database Server or use SSH to access the server.

2. Log in as em7admin with the appropriate password.

3. First, you should check the status of the appliances. To do this, enter the following at the shell prompt:

cat /proc/drbd
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4. Your output will look like this:

1: cs:Connected ro:Primary/Secondary ds:UpToDate/UpToDate C r----
ns:17567744 al:0 bm:1072 lo:0 pe:0 ua:0 ap:0 ep:1 wo:b oos:12521012

NOTE: If your output includes "ro:Primary/Secondary", but does not include "UpToDate/UpToDate",
data is being synchronized between the two appliances. You must wait until data
synchronization has finished before rebooting.

5. Execute the following commands on the primary appliance to pause the system and shutdown MariaDB.
Enter the password for the em7admin user when prompted:

sudo touch /tmp/.proc_mgr_pause
sudo systemctl stop pacemaker

6. Execute the following command on the primary appliance to reboot the appliance:

sudo reboot

7. After the primary appliance has rebooted, log in to the console of the primary appliance again.

8. Execute the following commands on the primary appliance:

sudo rm /tmp/.proc_mgr_pause

9. Enter the password for the em7admin user and confirm the command when prompted.

10. Log in to the secondaryDatabase Server as the em7admin user using the console or SSH.

11. Execute the following command on the secondary appliance to reboot the appliance:

sudo reboot

12. Enter the password for the em7admin user when prompted.
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Two Database Servers in a High Availability Cluster

Perform the following steps to reboot two Database Servers in a high availability cluster:

1. Either go to the console of the secondary Database Server or use SSH to access the server.

2. Log in as em7admin with the appropriate password.

3. First, you should check the status of the appliances. To do this, enter the following at the shell prompt:

cat /proc/drbd

4. Your output will look like this:

1: cs:Connected ro:Secondary/Primary ds:UpToDate/UpToDate C r----
ns:17567744 al:0 bm:1072 lo:0 pe:0 ua:0 ap:0 ep:1 wo:b oos:12521012

NOTE: If your output includes "ro:Secondary/Primary", but does not include "UpToDate/UpToDate", data is
being synchronized between the two appliances. You must wait until data synchronization has finished
before rebooting.

5. Execute the following command on the secondary appliance to stop the cluster service:

sudo systemctl stop pacemaker

6. Enter the password for the em7admin user when prompted.

7. Log in to the primaryDatabase Server as the em7admin user using the console or SSH.

8. Execute the following commands on the primary appliance to pause the system and stop the cluster service.
Enter the password for the em7admin user when prompted:

sudo touch /tmp/.proc_mgr_pause
sudo systemctl stop pacemaker

9. Execute the following command on the primary appliance to reboot the appliance:

sudo reboot

10. After the primary appliance has rebooted, log in to the console of the primary appliance again.

11. Execute the following command on the primary appliance:

sudo rm /tmp/.proc_mgr_pause

12. Enter the password for the em7admin user and confirm the command when prompted.

13. Ensure that the user interface is now available on the primary appliance.

14. Log in to the secondaryDatabase Server as the em7admin user using the console or SSH.

15. Execute the following command on the secondary appliance to reboot the appliance:

sudo reboot

16. Enter the password for the em7admin user when prompted.
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Three Database Servers Configured for High Availability and Disaster
Recovery

Perform the following steps to reboot three Database Servers configured for high availability and disaster recovery:

1. Either go to the console of the secondary Database Server in the HA cluster or use SSH to access the
server.

2. Log in as em7admin with the appropriate password.

3. First, you should check the status of the appliances. To do this, enter the following at the shell prompt:

cat /proc/drbd

4. Your output will look like this:

10: cs:Connected ro:Secondary/Primary ds:UpToDate/UpToDate C r----
ns:17567744 al:0 bm:1072 lo:0 pe:0 ua:0 ap:0 ep:1 wo:b oos:12521012

NOTE: If your output includes "ro:Secondary/Primary", but does not include "UpToDate/UpToDate", data is
being synchronized between the two appliances. You must wait until data synchronization has finished
before rebooting.

5. Execute the following command on the secondary Database Server in the HA cluster to stop the cluster
service:

sudo systemctl stop pacemaker

6. Enter the password for the em7admin user when prompted.

7. Log in to primaryDatabase Server as the em7admin user using the console or SSH.

8. Execute the following commands on the primary appliance to pause the system and stop the cluster service.
Enter the password for the em7admin user when prompted:

sudo touch /tmp/.proc_mgr_pause
sudo systemctl stop pacemaker

9. Execute the following command on the primary appliance to reboot the appliance:

sudo reboot

10. After the primary appliance has rebooted, log in to the console of the primary appliance again.

11. Execute the following command on the primary appliance:

sudo rm /tmp/.proc_mgr_pause

12. Enter the password for the em7admin user and confirm the command when prompted.

13. Log in to the secondary Database Server in the HA cluster as the em7admin user using the console or
SSH.
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14. Execute the following command on the secondary Database Server in the HA cluster to reboot the
appliance:

sudo reboot

15. Enter the password for the em7admin user when prompted.

16. Log in to the Database Server for Disaster Recovery as the em7admin user using the console or SSH.

17. Execute the following command on the Database Server for Disaster Recovery to reboot the appliance:

sudo reboot

18. Enter the password for the em7admin user when prompted.

Deprecated Features

As of the 8.2.0 release, the following PowerPacks are no longer included in the default ISO. These PowerPacks
will not be automatically removed from an existing system during an upgrade and will remain available for
download on the ScienceLogic Portal:

l ADIC Base Pack

l Ascend Communications Base Pack

l Cabletron System Base Pack

l CloudKick Management

l GoGrid Base Pack

l Informant Cluster

l Informant Exchange

l Informant MS SQL

l Informant Windows OS

l NTI Base Pack

l Rackspace Base Pack

l Redback Base Pack

l RIM Blackberry Base Pack

l Sensatronics Base Pack

l SystemEdge Base Pack

l System Uptime

l Tipping Point Base Pack

l Xirrus Base Pack
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The new user interface architecture requires API access for all users; API access is automatically granted to users.
The following API-specific access hooks have been deprecated and removed from the product:

l API: Resource Indexes

l API: Server Access

l API: Virtual Device

The following functionality that was available in previous releases is no longer available in the 8.12.1 release:

l The process for generating rollup/normalized data has been updated to improve performance and
scalability. This update deprecates the generation of frequent rollup data. The following user interface pages
are affected:

o The widgets Leaderboard/Top-N, Leaderboard/Top-N (secondary), and Multi-Series Performance no
longer support Frequent normalization. If these widgets are used by older dashboards and are already
configured to use Frequent normalization, the platform will automatically update these widgets to use
hourly normalization.

o In the Collection Labels page (System > Manage > Collection Labels), the Frequent Data column is
deprecated.

l The Cisco Nexus PowerPack has been removed from the default build and is no longer supported. However,
the PowerPack is not deleted during the upgrade process. The device classes for Cisco Nexus devices are
now included in the Cisco: Base Pack PowerPack.

l The ScienceLogic Agent no longer supports 32-bit versions of Linux or Windows.

l The third-party Azure python library has been removed from the ISO build.

l The FTP, SFTP, NFS, and SMB backup options that stage locally are no longer supported.

l The EMC Base Pack PowerPack has been removed from the default build and is no longer supported.
However, the PowerPack is not deleted during the upgrade process. If you are still using the EMC Base Pack
PowerPack, ScienceLogic recommends using the EMC: VNX PowerPack instead.

l The SAN wizard is no longer supported. ScienceLogic will no longer provide direct support for configuring a
SAN for data storage.

l Integration Server appliances are no longer supported.

l Root access is not enabled on any appliance.

l The VMware: vCloud PowerPack has been removed from the ISO build and is no longer supported.

l The "ifconfig" command is no longer supported by the new appliance operating system. The "ip addr"
command must be used instead.

l NOC Screens (System > Manage > Screens) are no longer included in the platform. To re-enable this
feature, contact ScienceLogic Customer Support.

l The Knowledge Base is no longer supported by ScienceLogic and will be disabled by default for new users.

l High-Availability and Disaster Recovery no longer support the command "drbd-overview". To check the status
of drbd, use "cat /proc/drbd".

l System Update no longer supports the shell command "deploy_patch".
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Known Issues

For a list of Known Issues and workarounds, see the ScienceLogic Cusotmer Portal at
https://support.sciencelogic.com/s/topic/0TO0z000000E6w7GAC/known-issues.
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